nyoj 715 Adjacent Bit (码数+打表)_第六届河南省程序设计大赛

Adjacent Bit Counts

时间限制:1000 ms  |  内存限制:65535 KB

难度:4

描述

For a string of n bits x1,x2,x3,…,xn,the adjacent bit count of the string is given by fun(x)=x1*x2+x2*x3+x3*x 4+…+xn-1*xnwhich counts the number of times a 1 bit is adjacent to another 1 bit.For example:

Fun(011101101)=3

Fun(111101101)=4

Fun(010101010)=0

Write a program which takes as input integers n and p and returns the number of bit strings x of n bits(out of 2ⁿ)that satisfy Fun(x)=p.

For example,for 5 bit strings,there are 6 ways of getting fun(x)=2:

11100,01110,00111,10111,11101,11011

输入

On the first line of the input is a single positive integer k,telling the number of test cases to follow.1≤k≤10 Each case is a single line that contains a decimal integer giving the number(n)of bits in the bit strings,followed by a single space,followed by a decimal integer(p)giving the desired adjacent bit count.1≤n,p≤100

输出

For each test case,output a line with the number of n-bit strings with adjacent bit count equal to p.

样例输入

2

5 2

20 8

样例输出

6

63426

题意: 长度为n的0,1字符串按照下面的公式,组成值为p的个数1≤n,p≤100

fun(x)=x1*x2+x2*x3+x3*x 4+…+xn-1*xn

例如:

Fun(011101101)=3

Fun(111101101)=4

Fun(010101010)=0

f[i][j][0] 长度为j的串第j位是0时组成值为i的个数;f[i][j][0]=f[i][j-1][1]+f[i][j-1][1];

f[i][j][1] 长度为j的串第j位是1时组成值为i的个数;f[i][j][1]=f[i-1][j-1][1]+f[i-1][j-1][0];

初始化:f[0][1][0]=f[0][1][1]=1;

#include<stdio.h>

long long f[105][105][2];

void init()
{//打表
	f[0][1][0]=1;
	f[0][1][1]=1;
	for(int i=2;i<=100;i++)
	{
		f[0][i][0]=f[0][i-1][0]+f[0][i-1][1];
		f[0][i][1]=f[0][i-1][0];
	}
	for(int i=1;i<=100;i++)
		for(int j=2;j<=100;j++)
		{
			f[i][j][0]=f[i][j-1][1]+f[i][j-1][0];
			f[i][j][1]=f[i-1][j-1][1]+f[i][j-1][0];
		}
}
int main()
{
	init();
	int k,n,p;
	scanf("%d",&k);
	while(k--)
	{
		scanf("%d%d",&n,&p);
		printf("%lld\n",f[p][n][0]+f[p][n][1]);
	}
}


x1y2 x2y3 x3y1-x1y3-x2y1-x3y2 是计算三角形面积的公式中的一部分。 在这个公式中,x1、x2、x3分别表示三角形的三个顶点的x坐标,y1、y2、y3分别表示三角形的三个顶点的y坐标。通过计算这个表达式的值,可以得到三角形的面积。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [TetraCluster:使用并行Java 2库的Java并行程序。 该程序在群集并行计算机上运行,​​以从给定的点集中找到...](https://download.csdn.net/download/weixin_42171208/18283141)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *2* [线性代数有个题,求正交变换x=Qy,化二次型f(x1,x2,x3)=8x1x2+8x1x3+8x2x3为标准型求出特征值](https://blog.csdn.net/weixin_39956182/article/details/115882118)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *3* [nyoj-67-三角形面积(S=(1/2)*(x1y2+x2y3+x3y1-x1y3-x2y1-x3y2))](https://blog.csdn.net/weixin_30492601/article/details/99541033)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值