hdu 2830

Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2198    Accepted Submission(s): 1473


Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

Output
Output one line for each test case, indicating the maximum possible goodness.

Sample Input

3 4

1011

1001

0001

3 4

1010

1001

0001

Sample Output

4

2

题意:给你一个0,1组成的N*M矩阵,可以移动任意两列任意次。问由“1”构成的最大的矩形的面积是多少(也就是1 的个数);

可以用贪心,求出每一行的深度,把每一行的一列元素按照从大到小的顺序排列,比较每一行可延伸到的列的面积a[i][j]*(j+1)跟新max_ans的值;

 qsort二维数组某行元素排序的做法:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 1010
char map[N][N];
int a[N][N];

int cmp(const void *a,const void *b)
{
	return *(int *)b-*(int *)a;//降序 
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		int i,j;
		for(i=0;i<n;i++)
			scanf("%s",map[i]);
		for(i=0;i<m;i++)
			a[0][i]=map[0][i]-'0';
		for(j=0;j<m;j++)
		for(i=1;i<n;i++)
	    {
	    	if(map[i][j]=='1')
	    		a[i][j]=a[i-1][j]+1;
	    	else
	    		a[i][j]=0;
		}
		int ans=0,res=0;
		for(i=0;i<n;i++)
		{
			qsort(a[i],m,sizeof(a[i][0]),cmp);
			for(j=0;j<m;j++)
			{
				res=a[i][j]*(j+1);
				ans=ans>res?ans:res;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
 } 

sort一维排序做法

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1005
int a[N],h[N];
char map[N][N]; 
bool cmp(int a,int b){
	return a>b;
}
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int ans=0;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				scanf(" %c",&map[i][j]);//输入要小心 
				if(map[i][j]=='1')
					a[j]++;
				else
					a[j]=0;
				h[j]=a[j]; 
			} 
			sort(h+1,h+m+1,cmp);
			for(int j=1;j<=m;j++)
			{
				ans=ans>h[j]*j?ans:h[j]*j;
			}
		}
     	printf("%d\n",ans);
	}
	return 0;
 } 

 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值