金牌、银牌、铜牌
Problem Description
Acm——大学中四大竞赛之首——是极具挑战性的大学生竞赛形式。在一场acm比赛中,一个参赛队伍由三人组合而成,在最短的时间内做出尽可能多的题目而且要尽量少提交错误代码,这样才能得到更高的排名。现在让我们模拟一次不正规的acm比赛,假设在比赛开始后30分钟(这时已经有不少同学提交了代码,在rating中已经出现),到比赛结束前,又有新的同学提交(在rating中出现),同时rating在不断变化着,还有一些同学因为一些原因中途退出比赛(这时rating中自动删除,当然在正式比赛中不会有这种情况)。最后终于比赛结束啦,看看rating,都有谁能拿到奖牌呢?
Input
第一行一个整数n(n<=1000),代表开始比赛后30分钟已经有n个人提交了代码。从第二行到第n+1行每行包括名字name(小于20个字符),分数p(0<=p<=10000),同时行数代表目前排名情况,第二行的排名第一,第三行排名第二,依次类推。
从第n+2行起,每行有一个字符,是A,Q,C,S,O中的一个:
A代表新加进rating中一名同学,紧随其后是名字name(小于20个字符),分数p(0<=p<=10000);
Q代表有一名同学退出了,接着是他的名字name(小于20个字符);
C代表有一个人的分数发生的改变,接着是此人的名字name,他的分数加多少(分数只会增加不会减少);
S代表一次显示此时rating的请求,这时输出所有在rating中的同学名字及他们的分数。
O代表比赛结束。
Output
对每次请求,输出此时rating中的所有同学名字和对应分数,在比赛结束时输出金牌获得者(一名),银牌获得者(两名),铜牌获得者(三名)(测试数据保证此时有至少6名同学在rating上)。注意:有同学添加到rating中或者分数改变后,在rating中有和这名同学有相同的分数,那么这名同学排在最后一个与他有相同分数同学的后面。
Example Input
7cze 90qch 87zff 70shangcf 66zhaohq 50zhrq 46yah 20A pc 56Q zffC qch 4SA von 66O
Example Output
qch 91cze 90shangcf 66pc 56zhaohq 50zhrq 46yah 20#1 : qch#2 : cze shangcf von#3 : pc zhaohq zhrq
#include<stdio.h> #include<stdlib.h> #include<string.h> struct node { int a; char name[26]; struct node * next; }; struct node * create (int n) { int i; struct node *head, *p, *tail; head= (struct node *) malloc (sizeof (struct node )); head->next=NULL; tail=head; for(i=0;i<n;i++) { p= (struct node *) malloc (sizeof (struct node )); scanf("%s%d",p->name,&p->a); p->next=NULL; tail->next=p; tail=p; } tail->next=NULL; return (head); } struct node * order (struct node * head) { int tmp; char st[26]; struct node * p, *q; for(p=head->next;p!=NULL;p=p->next) { for(q=p->next;q!=NULL;q=q->next) { if(p->a < q->a) { tmp=p->a; p->a=q->a; q->a=tmp; strcpy(st,p->name); strcpy(p->name,q->name); strcpy(q->name,st); } } } return (head); }
struct node * dele (struct node *head,char st[]) { struct node *p,*q; p=head; while(q!=NULL) { q=p->next; if(strcmp(st,q->name)==0) { p->next=q->next; free (q); break; } if(q!=NULL) { p=q; } } return (head); }
struct node * search (struct node *head ,char str[], int t) { struct node *p; p=head->next; while(p!=NULL) { if(strcmp(str,p->name)==0) { p->a += t; break; } p=p->next; } return (head); } void show (struct node * head) { struct node *p ; p=head->next; while(p!=NULL) { printf("%s %d\n",p->name,p->a); p=p->next; }
} void show1 (struct node * head) { int i,j; struct node *p,*q; for(i=1;i<=3;i++) { printf("#%d :",i); for(j=1;j<=i;j++) { if(i==1) { p=head->next; q=p->next; printf(" %s",p->name); } else { p=p->next; q=p->next; printf(" %s",p->name); } }
for(;;p=p->next,q=q->next) { if((p->a == q->a)&&(q!=NULL)) { printf(" %s",q->name); } else { break; } }
printf("\n"); } } struct node * charu (struct node *head,struct node *p) { struct node * q, *t; t=head; for(q=head->next;q!=NULL;q=q->next,t=t->next) { if(p->a > q->a) { p->next=t->next; t->next=p; break; } } return (head); } int main() { int n; char c; int t; char st[26]; char str[26]; char s[26]; struct node *head , *p; scanf("%d",&n); head=create(n);
while((c=getchar())!='O') { if(c=='A') { p= (struct node *) malloc (sizeof (struct node )); scanf("%s%d",p->name,&p->a); p->next=NULL; head=charu(head,p); } else if(c=='Q') { scanf("%s",st); head=dele (head,st); } else if(c=='C') { scanf("%s%d",str,&t); head=search(head,str,t); head=order(head); } else if(c=='S') { show(head); } } show1 (head); return 0; }
代码有些问题,仅做参考,欢迎改正。