1044. 火星数字(20)

火星人是以13进制计数的:

  • 地球人的0被火星人称为tret。
  • 地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
 
 
写的不好这个
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
using namespace std;
int main()
{
	string x[13]={"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec",};
	string y[12]={"tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou",};					
	int n;
	cin>>n;
	getchar();
	char s[8];
	while(n--)
	{
		gets(s);
		if(s[0]>='0'&&s[0]<='9')
		{
			int a=atoi(s);
			do
			{
				if(a/13>0)
				{
					if(a%13)
					cout<<y[a/13-1]<<" ";
					else
					cout<<y[a/13-1];
				}
				
				else
				{
					cout<<x[a];break;
				}
				a%=13;
			}while(a);
			cout<<endl;	
		}
		else 
		{
			int temp=0;
			int sum =0; 
			for(int i=0;i<strlen(s);i++)//一共两种情况 一个英文单词 两个英文单词 
			{
				if(s[i]==' ')
				{
					string z;
					for(int j=0;j<i;j++)
					z+=s[j];
					for(int j=0;j<13;j++)
					if(z==y[j])
					sum=13*(j+1);
				}
				if(i==strlen(s)-1)
				{
					string z;
					for(int j=i-2;j<=i;j++)
					z+=s[j];
					for(int j=0;j<13;j++)
					if(z==x[j])
					sum+=j;
					for(int j=0;j<13;j++)
					if(z==y[j])
					sum+=13*(j+1);
				}
			}
			cout<<sum<<endl;
		}
		return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值