2018-7-28第二次训练赛-B

B - Number Sequence

HDU - 1005

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0

Sample Output

2
5

兔子序列变形题目,由于结果mod7,根据简单推理可以知道在第7*7+1=50项之内必然找到循环

(...ab......ab...将各个结果写成一排之后只需找到这种情况即可)

(由于当时出现了个小bug,我把数组调到了501大小)


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>

using namespace std;

int data[501]={1,1,1};

int main()
{
    int a,b,n;
    int i,j;
    bool flag;
    while (~scanf("%d%d%d", &a, &b, &n) && n) {

        for (i=3; i<=500; i++){
            data[i] = (a * data[i-1] + b * data[i-2])%7;
            //printf("%d:%d\n", i, data[i]);
        }

        flag = false;
        for (i=2; i<=499; i++) {
            for (j=1; j<i; j++) {
                if (data[i]==data[j] && data[i+1]==data[j+1]) {
                    flag = true;
                    break;
                }

            }
            if (flag) {
                break;
            }
        }

        if (n <= 500) {
            printf("%d\n", data[n]);
        }
        else {
            printf("%d\n", data[ (n-j)%(i-j)+j ]);
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值