H - Prime Ring Problem
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
经典的素数环问题
回溯法不多解释
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
using namespace std;
bool pri[41]={0,
0,1,1,0,1,0,1,0,0,0,
1,0,1,0,0,0,1,0,1,0,
0,0,1,0,0,0,0,0,1,0,
1,0,0,0,0,0,1,0,0,0
};
int a[21];
bool check(int i) {
int j=1;
while (j<i) {
if (a[i] == a[j])
return false;
j++;
}
return true;
}
void put(int n) {
int i=1;
while (i<n) {
printf("%d ", a[i++]);
}
printf("%d\n", a[i]);
}
int main()
{
int c = 1;
int n;
int i;
while (~scanf("%d", &n)) {
printf("Case %d:\n", c++);
fill(a,a+n+1,0);
a[1] = a[2] = 1;
i=2;
while (true) {
a[i]++;
if (a[i] > n) {
if (i == 2) {
break;
}
a[i] = 0;
i--;
continue;
}
if (!pri[ a[i]+a[i-1] ] || !check(i))
continue;
if (i == n && pri[ a[i]+a[1] ])
put(n);
else
i++;
}
printf("\n");
}
return 0;
}