2018-7-28第二次训练赛-H

H - Prime Ring Problem

HDU - 1016

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

经典的素数环问题

回溯法不多解释


#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>

using namespace std;

bool pri[41]={0,
    0,1,1,0,1,0,1,0,0,0,
    1,0,1,0,0,0,1,0,1,0,
    0,0,1,0,0,0,0,0,1,0,
    1,0,0,0,0,0,1,0,0,0
};

int a[21];

bool check(int i) {
    int j=1;
    while (j<i) {
        if (a[i] == a[j])
            return false;
        j++;
    }
    return true;
}

void put(int n) {
    int i=1;
    while (i<n) {
        printf("%d ", a[i++]);
    }
    printf("%d\n", a[i]);
}

int main()
{
    int c = 1;
    int n;
    int i;
    while (~scanf("%d", &n)) {
        printf("Case %d:\n", c++);

        fill(a,a+n+1,0);
        a[1] = a[2] = 1;
        i=2;
        while (true) {
            a[i]++;
            if (a[i] > n) {
                if (i == 2) {
                    break;
                }
                a[i] = 0;
                i--;
                continue;
            }
            if (!pri[ a[i]+a[i-1] ] || !check(i))
                continue;
            if (i == n && pri[ a[i]+a[1] ])
                put(n);
            else
                i++;
        }
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值