More is better (九度 OJ 1444)

More is better (九度 OJ 1444)

时间限制:1 秒 内存限制:100 兆 特殊判题:否

1.题目描述:

Mr Wang wants some boys to help him with a project. Because the project israther complex, the more boys come, the better it will be. Of course there are certainrequirements. Mr Wang selected a room big enough to hold the boys. The boy who are
not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
输入:
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B≤ 10000000)
输出:
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
样例输入:
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
样例输出:
4
2

2.基本思路
本题的求解目标为求得最大的连通分量中结点的个数,同样采用并查集的思想。但由于需要记录连通分量中结点的个数,因此需要另外采用一个数组sum[N]存储,数组元素sum[i]表示以结点i为根结点的集合中包含的元素的个数。初始化时数组sum中所有的元素均为1,合并两个集合时,其中集合1的根结点为i,集合2的根结点为j,将结点i作为结点j的根结点,那么有如下关系sum[i]+=sum[j],最后将sum数组遍历一遍得到sum[i]中的最大值。

3.代码实现

#include <iostream>
#define N 10000001

using namespace std;

int Tree[N];
int sum[N];
int n;
int findRoot(int x){
    int tmp;
    if(Tree[x]==-1){
        return x;//x为集合的根结点
    }
    else{
        tmp = findRoot(Tree[x]);
        Tree[x] = tmp;//每次查询的时候,把查询到的父节点不是根结点的结点的父节点都置为根结点
                      //路径压缩,防止并查集树退化为线性结构。
    }
    return tmp;
}

int main()
{
    int ans;
    int c1,c2;
    int r1,r2;

    while(scanf("%d",&n)!=EOF){
        ans = 0;
        for(int i=0;i<N;i++){
            Tree[i] = -1;
            sum[i] = 1;
        }
        for(int i=0;i<n;i++){
            scanf("%d%d",&c1,&c2);
            r1 = findRoot(c1);
            r2 = findRoot(c2);
            if(r1!=r2){
                Tree[r1]=r2;//合并两个集合
                sum[r2] += sum[r1];
            }

        }
        for(int i=1;i<=N;i++){
            if(Tree[i]==-1&&sum[i]>ans){
                ans=sum[i];
            }
        }
        printf("%d\n",ans);//结果为
    }
    return 0;
}
/*
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值