Leagal or Not (九度 OJ 1448)

Leagal or Not (九度 OJ 1448)

时间限制:1 秒 内存限制:128 兆 特殊判题:否

1.题目描述:

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh,AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by,there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless, some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same
time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.

输入:
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <=100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0. TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.
输出:
For each test case, print in one line the judgement of the messy relationship.If it
is legal, output “YES”, otherwise “NO”.

样例输入:
3 2
0 1
1 2
2 2
0 11 0
0 0
样例输出:
YES
NO

2.基本思路

该题所要求解的目标用数学的语言进行描述就是,判断该结点和边构成的图是否为有向无环图。即利用拓扑排序的思想,每次取出图中入度为0的结点,从图中去掉该结点,然后去掉以该结点作为弧尾的边,以此反复,直到不存在入度为0的结点,如果此时图中所有的结点均已拓扑排序完毕,那么该图就是有向无环图,否则图中必定存在环路。该算法的时间复杂度为O(N+E)其中N为结点的个数,E为边的数量。

3.代码实现

#include <iostream>
#include <vector>
#include <queue>

#define N 101
using namespace std;

vector<int> edge[N];//邻接链表,用于存储图中存在的边
queue<int> Q;//该队列用于存储当前图中入度为0的结点
int inDreege[N];//存储每个结点的入度

int main()
{
    int n,m;
    int n1,n2;
    while(scanf("%d%d",&n,&m)!=EOF){

        if(m==0&&n==0)break;

        for(int i=0;i<n;i++){
            edge[i].clear();
            inDreege[i]=0;
        }

        for(int i=0;i<m;i++){//输入m条边
            scanf("%d%d",&n1,&n2);//n1->n2
            edge[n1].push_back(n2);
            inDreege[n2]++;
        }

        while(Q.empty()==false){//清空队列
            Q.pop();
        }

        for(int i=0;i<n;i++){//将入度为0的结点加入到队列中
            if(inDreege[i]==0)
                Q.push(i);
        }

        int cnt=0;//记录已经拓扑排序好的结点个数

        while(Q.empty()==false){
            int t = Q.front();//取队头元素
            Q.pop();
            cnt++;
            for(int i=0;i<edge[t].size();i++){
                inDreege[edge[t][i]]--;
                if(inDreege[edge[t][i]]==0)
                    Q.push(edge[t][i]);
            }

        }
        if(cnt==n)//所有的结点均已经拓扑排序完毕
            printf("YES\n");
        else
            printf("NO\n");

    }
    return 0;
}

/*
样例输入:
3 2
0 1
1 2
2 2
0 1
1 0
0 0
样例输出:
YES
NO
*/
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值