Least Common Multiple(九度教程第 49 题)

Least Common Multiple(九度教程第 49 题)

时间限制:1 秒 内存限制:32 兆 特殊判题:否

1.题目描述:

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1

Sample Output
105 10296

Source
East Central North America 2003, Practice

2.基本思路

该问题为求多个数的最小公倍数问题,本质上就是两两之间求解最小公倍数,然后将所得的公倍数作为集合中的元素与下一个数继续求最小公倍数。
注意!!!
有一个很小的细节,
求解最小公倍数的公式为:

LCM = a*b/gcd(a,b);

上述的写法是有问题的,因为在执行a*b的时候很容易导致数据溢出,所以为了避免数据溢出一般先执行除法操作再执行乘法操作。hdu的oj就卡了这个细节,不知有多少人掉坑了。。

LCM = a/gcd(a,b)*b;

3.代码实现

#include <iostream>
#define N 10000
using namespace std;

int gcd(int a, int b){
    int tmp;
    if(b==0)return a;
    else
        while(b!=0){
            tmp = a%b;
            a = b;
            b = tmp;
        }
    return a;
}

int buf[N];
int main()
{
    int n;
    int m;
    int a,b;
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        scanf("%d",&m);
        a = 1;
        for(int i=1;i<=m;i++){
            scanf("%d",&b);
            a = a/gcd(a,b)*b;
        }
        printf("%d\n",a);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值