Goldbach's Conjecture(九度教程第53 题)

Goldbach's Conjecture(九度教程第53 题)

时间限制:1 秒 内存限制:32 兆 特殊判题:否

1.题目描述:

Goldbach’s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.

Output
Each output line should contain an integer number. No other characters should appear in the output.

Sample Input
6
10
12
0

Sample Output
1
2
1

Source
Asia 1998, Tokyo (Japan)


2.基本思路

采用素数筛的方法标记2~1000000内的所有素数,并将素数存储到数组prime[N]当中,然后从小遍历prime[N]判断k-prime[i]是否为素数。是则输出,否则继续往后查找。


3.代码实现

#include <iostream>
#include <string.h>

#define N 32768

using namespace std;
bool mark[N];//false表示未标记,是素数
int prime[N];
int primeSize=0;

void init(){
    for(int i=0;i<N;i++){
        mark[i]=false;
    }
    mark[0]=true;
    mark[1]=true;
    for(int i=2;i<=N;i++){
        if(mark[i]==true)
            continue;//跳过被标记的元素
        else{
            prime[primeSize++]=i;
            for(int j=i*i;j<N;j++){
                if(j%i==0 && mark[j]==false)
                    mark[j]=true;
            }
        }
    }
}

int main()
{
    int k=0;
    init();
    while(scanf("%d",&k)!=EOF){
        if(k==0)break;
        int cnt=0;
        for(int i=0;i<primeSize;i++){
            if(k/2<prime[i]){
                break;
            }
            if(mark[k-prime[i]]==false){
                cnt++;
            }

        }
        printf("%d\n",cnt);
    }
    return 0;
}
/*
6
10
12
0
*/

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值