Piggy-Bank (九度教程第 102 题)

Piggy-Bank (九度教程第 102 题)

时间限制:1 秒 内存限制:32 兆 特殊判题:否

1.题目描述:

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig.
After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that
there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside.Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst
case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
输入:
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F.They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <=F <= 10000. On the second line of each test case, there is an integer number N (1 <=
N <= 500) that gives the number of various coins used in the given currency.Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.
输出:
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.
样例输入:
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
样例输出:
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

2.基本思路

首先先定位问题,对号入座。回顾我们讲过的几类问题,该问题属于完全背包问题,且必须刚好装满背包,同时有点区别的地方就是最后要求的是所能装得的最小价值。对于刚好装满的要求,我们只需采用以下初始化方式 d p [ 0 ] = 0 , d p [ i ] = I N T _ M A X ( 1 ≤ i ≤ c ) dp[0]=0,dp[i]=INT\_MAX(1≤i≤c) dp[0]=0,dp[i]=INT_MAX(1ic)即可,之所以不可达的状态初始化为INT_MAX是因为该问题要求的是最小值,采用该初始化的方式有利于min函数求解最小值。对于完全背包问题,我们只需从前往后遍历规划数组即可。

3.代码实现

#include <iostream>
#include <climits>
#define N 501
#define C 10001
using namespace std;

int min(int a,int b){return a<b?a:b;}
int max(int a,int b){return a>b?a:b;}

int weight[N],value[N];
int dp[C];
int main()
{
    int T,E,F,n,c;
    scanf("%d",&T);
    for(int Case=1;Case<=T;Case++){
        scanf("%d%d",&E,&F);
        c = F-E;//背包的容量
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d%d",&value[i],&weight[i]);
        }
        for(int i=0;i<=c;i++){//必须要装满,所以初始化的过程不同
            if(i==0)
                dp[i]=0;
            else
                dp[i]=INT_MAX;
        }
        for(int i=1;i<=n;i++){
            for(int j=weight[i];j<=c;j++){
                if(dp[j-weight[i]]!=INT_MAX)//只有dp[j-weight[i]]的状态是可达才和当前值取最小值
                    dp[j]=min(dp[j],dp[j-weight[i]]+value[i]);
            }
        }
         if(dp[c]==INT_MAX)
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[c]);

    }

    return 0;
}
/*
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值