hdu2196-Computer

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 32652    Accepted Submission(s): 4625


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
 
 
5 1 1 2 1 3 1 1 1
 

Sample Output
 
 
3 2 3 4 4
 

Author
scnu
 

Recommend

lcy

题意:公司要举办party,有n个员工,每个员工只有一个唯一的直属上司(根节点没有)员工和直属上司不能同时参加宴会。每个人有一个ratings,求参加宴会的合法情况中最大的ratings和并输出。

题解:首先建立树,因为不确定最顶层是否只有一个,所以虚拟一个老板节点0,最顶层的节点的直属上司是老板。从老板开始,如果当前点的ratings要加,则下属节点不能加。如果当前点的ratings不加,则下属节点的可加可不加。

设dp[i][0]为不加i号节点,其子树的最大ratings和,dp[i][1]为加i好节点,其子树的最大ratings和,则递归一遍即可~

dp数组的用意是避免重复计算!

AC代码

#include <iostream>
#include <queue>
#include <algorithm>
#include <vector>

using namespace std;

const int maxn = 6e3 + 10;
int rat[maxn], vis[maxn];
vector<int> son[maxn];
int dp[maxn][2];

int dfs(int n, int x){
	int len = son[n].size();
	int ans = 0;
	if(x == 1)
		ans = rat[n];
	for(int i = 0; i < len; i++){
		int v = son[n][i];
		if(x == 0){
			if(dp[v][0] == -1)
				dp[v][0] = dfs(son[n][i], 0);
			if(dp[v][1] == -1)
				dp[v][1] = dfs(son[n][i], 1);
			ans += max(dp[v][0], dp[v][1]);
		}
		else{
			if(dp[v][0] == -1)
				dp[v][0] = dfs(son[n][i], 0);
			ans += dp[v][0];
		}
	}
	return ans;
}

int main(){
	int n, m, a, b;
	while(scanf("%d", &n) != EOF){
		for(int i = 1; i <= n; i++){
			scanf("%d", &rat[i]);
			son[i].clear(); 
			vis[i] = 0;
			dp[i][0] = dp[i][1] = -1;
		}
		rat[0] = 0;
		son[0].clear();
		while(scanf("%d %d", &a, &b) && (a + b)){
			son[b].push_back(a);
			vis[a]++;
		}
		for(int i = 1; i <= n; i++)
			if(vis[i] == 0)
				son[0].push_back(i);
		printf("%d\n", dfs(0, 0));
	}
	return 0;
}
今天开始学习树形dp,加油~~~
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值