poj-3345Bribing FIPA

12 篇文章 0 订阅
7 篇文章 0 订阅
Bribing FIPA
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5567 Accepted: 1762

Description

There is going to be a voting at FIPA (Fédération Internationale de Programmation Association) to determine the host of the next IPWC (International Programming World Cup). Benjamin Bennett, the delegation of Diamondland to FIPA, is trying to seek other delegation's support for a vote in favor of hosting IWPC in Diamondland. Ben is trying to buy the votes by diamond gifts. He has figured out the voting price of each and every country. However, he knows that there is no need to diamond-bribe every country, since there are small poor countries that take vote orders from their respected superpowers. So, if you bribe a country, you have gained the vote of any other country under its domination (both directly and via other countries domination). For example, if C is under domination of B, and B is under domination of A, one may get the vote of all three countries just by bribing A. Note that no country is under domination of more than one country, and the domination relationship makes no cycle. You are to help him, against a big diamond, by writing a program to find out the minimum number of diamonds needed such that at least m countries vote in favor of Diamondland. Since Diamondland is a candidate, it stands out of the voting process.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers n (1 ≤ n ≤ 200) and m (0 ≤ m ≤ n) which are the number of countries participating in the voting process, and the number of votes Diamondland needs. The next n lines, each describing one country, are of the following form:

CountryName DiamondCount DCName1 DCName1 ...

CountryName, the name of the country, is a string of at least one and at most 100 letters and DiamondCount is a positive integer which is the number of diamonds needed to get the vote of that country and all of the countries that their names come in the list DCName1 DCName1 ... which means they are under direct domination of that country. Note that it is possible that some countries do not have any other country under domination. The end of the input is marked by a single line containing a single # character.

Output

For each test case, write a single line containing a number showing the minimum number of diamonds needed to gain the vote of at least m countries.

Sample Input

3 2
Aland 10
Boland 20 Aland
Coland 15
#

Sample Output

20

Source

Tehran 2006

题意:有n个村子,每个村子一张票,某个人要买通至少m个村子,每个村子有个加个。同时,如果买通了一个有附属村子的村,则其子村也被买通,问最少要花费多少钱。

题解:树形dp + 背包水题。

设dp[i][j]为到达第i个存在及其子村,买通j个村子的费用。则如果买通了村子i,假设其子村加本身有num个存,则dp[i][num] = val[i];如果不买通村子i,则进行背包即可。

背包方程:dp[x][j] = min(dp[x][j], dp[x][k] + dp[v][j - k]);

AC代码

#include <stdio.h>
#include <iostream>
#include <string>
#include <queue>
#include <map>
#include <vector>
#include <algorithm>
#include <string.h>
#include <cmath>
#include <sstream>  
 
using namespace std;

const int maxn = 222, inf = 1 << 29;
char s[22222], name[maxn];
int dp[maxn][maxn], val[maxn], vis[maxn];
map<string, int> t;
vector<int> son[maxn];

int dfs(int x){
	int len = son[x].size();
	int num = 1;
	for(int i = 0; i < len; i++){
		int v = son[x][i];
		num += dfs(v);
	}
	for(int i = 0; i < len; i++){
		int v = son[x][i];
		for(int j = num - 1; j  >= 1; j--){
			for(int k = j - 1; k >= 0; k--){
				dp[x][j] = min(dp[x][j], dp[x][k] + dp[v][j - k]);
			}
		}
	}
	dp[x][num] = val[x];
	return num;
}

int main(){
	int n, m, u, v;
	while(gets(s)){
		t.clear();
		if(s[0] == '#')
			break;
		sscanf(s, "%d %d", &n, &m);
		int now = 1;
		for(int i = 0; i <= n; i++){
			vis[i] = 0;
			son[i].clear();
			for(int j = 1; j <= n; j++)
				dp[i][j] = inf;
			dp[i][0] = 0;
		}
		for(int i = 1; i <= n; i++){
			gets(s);
			stringstream Cin;
			Cin.str(s);
			Cin >> name;
			if(t[name] == 0)
				t[name] = now++;
			u = t[name];
			Cin >> val[u];
			while(Cin >> name){
				if(t[name] == 0)
					t[name] = now++;
				v = t[name];
				son[u].push_back(v);
				vis[v]++;
			}
		}
		for(int i = 1; i <= n; i++)
			if(vis[i] == 0)
				son[0].push_back(i);
		dfs(0);
		int ans = dp[0][m];
		for(int i = m + 1; i <= n; i++)
			ans = min(ans, dp[0][i]);
		printf("%d\n", ans);
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值