ZOJ-3201Tree of Tree

12 篇文章 0 订阅
7 篇文章 0 订阅
Tree of Tree

Time Limit: 1 Second       Memory Limit: 32768 KB

You're given a tree with weights of each node, you need to find the maximum subtree of specified size of this tree.

Tree Definition 
A tree is a connected graph which contains no cycles.

Input

There are several test cases in the input.

The first line of each case are two integers N(1 <= N <= 100), K(1 <= K <= N), where N is the number of nodes of this tree, and K is the subtree's size, followed by a line with N nonnegative integers, where the k-th integer indicates the weight of k-th node. The following N - 1 lines describe the tree, each line are two integers which means there is an edge between these two nodes. All indices above are zero-base and it is guaranteed that the description of the tree is correct.

Output

One line with a single integer for each case, which is the total weights of the maximum subtree.

Sample Input

3 1
10 20 30
0 1
0 2
3 2
10 20 30
0 1
0 2

Sample Output

30
40

题意:有一个n个点的树,每个点有个权值,问大小为k的子树的最大权值和为多少。

题解:树形背包水题。

设dp[x][j]为x点大小为j的子树的最大权值和,则dp[x][j] = max(dp[x][j], dp[x][k] + dp[v][j - k]);

任选一点为根往下搜索即可!

AC代码

#include <stdio.h>
#include <iostream>
#include <string>
#include <queue>
#include <map>
#include <vector>
#include <algorithm>
#include <string.h>
#include <cmath>
 
using namespace std;

const int maxn = 111, inf = 1 << 29;
int dp[maxn][maxn], n, k1, ans, val[maxn], vis[maxn];
vector<int> s[maxn];

struct node{
	int num, val;
	node(int n, int v):num(n), val(v){}
};

node dfs(int x){
	vis[x] = 1;
	int len = s[x].size();
	node m = node(1, val[x]);
	dp[x][1] = val[x];
	for(int i = 0; i < len; i++){
		int v = s[x][i];
		if(!vis[v]){
			node cc = dfs(v);
			m.num += cc.num;
			m.val += cc.val;
			for(int j = n; j >= 2; j--)
				for(int k = 1; k < j; k++){
					dp[x][j] = max(dp[x][j], dp[x][k] + dp[v][j - k]);
//					cout << x << " " << v << " " << j << " " << dp[x][j] << " " << dp[x][k] + dp[v][j - k] << endl;
				}
		}
	}
	ans = max(ans, dp[x][k1]);
	return m;
}

int main(){
	int a, b;
	while(scanf("%d %d", &n, &k1) != EOF){
		for(int i = 0; i < n; i++){
			vis[i] = 0;
			s[i].clear();
			for(int j = 0; j <= n; j++)
				dp[i][j] = 0;
		}
		for(int i = 0; i < n; i++)
			scanf("%d", &val[i]);
		for(int i = 1; i < n; i++){
			scanf("%d %d", &a, &b);
			s[a].push_back(b);
			s[b].push_back(a);
		}
		ans = -inf;
		dfs(0);
		printf("%d\n", ans);
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值