2018暑假第一次多校C题

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1092    Accepted Submission(s): 549
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

 

Sample Input

 

1 1 1 2 2 3 3 5

 

 

Sample Output

 

1 2 3

题意:给定一个n,然后给出3*n个点,保证任意三点不共线,求一组答案,分成n个三角形,要求三角形之间不能相交。

题解:不能相交,且任意三点不共线,所以先按x升序,再按y升序,从左到右取点即可!

代码:

#include <iostream>
#include <stdio.h>
#include <vector>
#include <string.h>
#include <algorithm>
#define ll long long

using namespace std;

struct node{
    int x,y,id;
    node(int a, int b, int c){
        x = a;
        y = b;
        id = c;
    }
};
bool cmp(node a1, node a2){
    if(a1.x!=a2.x)
        return a1.x < a2.x;
    return a1.y < a2.y;
}
vector<node> s;

int main(){
    int t,i,n,a ,b;
    while(scanf("%d", &t)!=EOF){
        while(t--){
            s.clear();
            scanf("%d", &n);
            for(int i = 0; i < n; i++){
                for(int j = 0; j < 3; j++){
                    scanf("%d %d", &a, &b);
                    s.push_back(node(a, b, i * 3 + j + 1));
                }
            }
            sort(s.begin(),s.end(),cmp);
            for(int i = 0; i < n; i++){
                printf("%d %d %d\n",s[i*3+0].id, s[i*3+1].id, s[i*3+2].id);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值