杭电6027 Easy Summation

Easy Summation

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/131072K (Java/Other)
Total Submission(s) : 10   Accepted Submission(s) : 2
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

You are encountered with a traditional problem concerning the sums of powers.
Given two integers n and k . Let f(i)=ik , please evaluate the sum f(1)+f(2)+...+f(n) . The problem is simple as it looks, apart from the value of n in this question is quite large.
Can you figure the answer out? Since the answer may be too large, please output the answer modulo 109+7 .

Input

The first line of the input contains an integer T(1T20) , denoting the number of test cases.
Each of the following T lines contains two integers n(1n10000) and k(0k5) .

Output

For each test case, print a single line containing an integer modulo 109+7 .

Sample Input

3
2 5
4 2
4 1

Sample Output

33
30
10

Source

2017中国大学生程序设计竞赛 - 女生专场


想法:看懂题目就简单啦!

关键的理解最后一句话please output the answer modulo 109+7 .

代码:

#include<stdio.h>
#include<math.h>
#include<math.h>
#define ws 1000000007
int n,k;
long long po(int i)
{
    int j;
    long long sum1=1;
    for(j=1;j<=k;j++)
    {
        sum1=sum1*i;
        sum1=sum1%ws;
    }
    return sum1;
}
long long a[10010];
int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        int i;
       scanf("%d %d",&n,&k);
       long long as=0;
       for(i=1;i<=n;i++)
       {
           as=as+po(i);
           as=as%ws;
       }
       printf("%lld\n",as);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值