POJ 2342Anniversary party(树形dp)

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8526 Accepted: 4909

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

Source

想法:

题意:话说一个公司的一些然要去参加一个party,每个人有一个愉悦值,而如果某个人的直接上司在场的话会非常扫兴,所以避免这样的安排,问给出n个人,每个人的愉悦值以及他们的上司所属关系,问你让那些人去可以让总的愉悦值最大,并求出这个值。

 分析:树形dp入门题目,这个公司的人事关系可以根据给出的数据得到一个树,最上面的是最高层,往下依次,我们要做的就是在树的节点处进行dp。
用dp【i】【0】表示当第i这个人不选,dp【i】【1】表示当第i这个人安排去参加
dp[o][0]+=max(dp[i][0],dp[i][1]);//父节点不选,子节点可选可不选
 dp[o][1]+=dp[i][0];//父节点已选,子节点不能选
代码:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define N 10000
int max(int a,int b)
{
    return a>b?a:b;
}
int dp[N][2];  ///dp[i][0]表示当前i点不选 1表示选
int father[N],vis[N];
int n;
void creat(int o)
{
    vis[o]=1;
    for(int i=1;i<=n;i++)
    {
        if(vis[i]==0 && father[i]==o)
        {
            creat(i);
            dp[o][0]+=max(dp[i][0],dp[i][1]);//父节点不选,子节点可选可不选
            dp[o][1]+=dp[i][0];//父节点已选,子节点不能选
        }
    }
}
int main()
{
    int i;
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        memset(father,0,sizeof(father));
        memset(dp,0,sizeof(dp));
        for(i=1; i<=n; i++)
        {
            scanf("%d",&dp[i][1]);
        }
        int f,c,root;
        root = 0;//记录父结点
        while(scanf("%d %d",&c,&f),c||f)
        {
            father[c] = f;
        }
        creat(root);
        int imax=max(dp[root][0],dp[root][1]);
        printf("%d\n",imax);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值