HDU1002A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

以前做过的题目,今天做不知道RE/TLE/WA了多少次。
1.超时是因为cnt=0,这个我忘了写进每次循环了。
2.WA有两个原因,第一个是我没从最低位开始加,而是想成了从最高位开始加了,第二个是因为输入的是一串字符串,忘记对最前面的0进行处理。
下面贴上终于AC了的代码:

#include<stdio.h>
#include<string.h> 
#define MAX 1005
char str1[MAX],str2[MAX];
int str3[MAX];//str1+str2=str3;
int main()
{
	int n,len1,len2;
	int cnt;//记录str3的长度
	int i1,i2,i,j,temp;
	int tag;//进位标识符 
	while(scanf("%d",&n)!=EOF)
	{
		for(j=1;j<=n;j++)
		{
			cnt=0;
			memset(str1,0,sizeof(str1));
			memset(str2,0,sizeof(str2));
			memset(str3,0,sizeof(str3));
			scanf("%s %s",&str1,&str2);
			tag=0;
			i1=0;i2=0;
			len1=strlen(str1)-1;
			len2=strlen(str2)-1;
			while(str1[i1++]=='0');
			while(str2[i2++]=='0');
			i1--;i2--;
			while(i1<=len1&&i2<=len2)
			{
				temp=(str1[len1--]-'0')+(str2[len2--]-'0')+tag;
				tag=temp/10;
				str3[cnt++]=temp%10;
			}
			while(i1<=len1)
			{
				temp=(str1[len1--]-'0')+tag;
				tag=temp/10;
				str3[cnt++]=temp%10;
			}
			while(i2<=len2)
			{
				temp=(str2[len2--]-'0')+tag;
				tag=temp/10;
				str3[cnt++]=temp%10;
			}
			if(tag==1)
				str3[cnt++]=1;
			printf("Case %d:\n",j);
			printf("%s + %s = ",str1,str2);
			int key=true;
			for(i=cnt-1;i>=0;i--)
				printf("%d",str3[i]);
			printf("\n");
			if(j!=n)
				printf("\n"); 
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值