HDU1715大菲波数

Problem Description
Fibonacci数列,定义如下:
f(1)=f(2)=1
f(n)=f(n-1)+f(n-2) n>=3。
计算第n项Fibonacci数值。

Input
输入第一行为一个整数N,接下来N行为整数Pi(1<=Pi<=1000)。

Output
输出为N行,每行为对应的f(Pi)。

Sample Input
5
1
2
3
4
5

Sample Output
1
1
2
3
5

#include<stdio.h>
#include<string.h>
#define MAX 1001
int a[MAX][MAX];
int len[MAX];//记录a[i]的一万进制有几位 
//逢1万进1
void get_table()
{
	memset(a,0,sizeof(a));
	a[1][0]=1;a[2][0]=1;
	len[1]=1;len[2]=1; 
	int cy,temp,k;
	for(int i=3;i<MAX;i++)
	{
		k=0;cy=0;
		while(k<len[i-1]&&k<len[i-2])
		{
			temp=a[i-1][k]+a[i-2][k]+cy;
			cy=temp/10000;
			a[i][k++]=temp%10000;
		}
		while(k<len[i-1])
		{
			temp=a[i-1][k]+cy;
			cy=temp/10000;
			a[i][k++]=temp%10000;
		}
		while(k<len[i-2])
		{
			temp=a[i-1][k]+cy;
			cy=temp/10000;
			a[i][k++]=temp%10000;
		}
		if(cy!=0)
			a[i][k++]=cy;
		len[i]=k;
	}
}
int main()
{
	int t,n;
	get_table();
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d",&n);
			printf("%d",a[n][len[n]-1]);
			for(int i=len[n]-2;i>=0;i--)
				printf("%04d",a[n][i]);
			printf("\n"); 
		}
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值