2018杭电多校day1_A Maximum Multiple HDU - 6298

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2606    Accepted Submission(s): 1091


 

Problem Description

Given an integer n , Chiaki would like to find three positive integers x , y and z such that: n=x+y+z , x∣n , y∣n , z∣n and xyz is maximum.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106 ), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106 ).

 

 

Output

For each test case, output an integer denoting the maximum xyz . If there no such integers, output −1 instead.

 

 

Sample Input

3 1 2 3

 

Sample Output

-1 -1 1

 

Source

2018 Multi-University Training Contest 1

队友找的规律 任意数分三份若要使三个数乘积最大,即需要三个数尽可能接近

故划分为1/3,1/3,1/3或者1/2,1/4,1/4.只需讨论情况即可

#include<bits/stdc++.h>

#define ms(a,x) memset(a,x,sizeof(a))
using namespace std;

#define N 200
#define MAX 2000000

typedef long long ll;
int main(){
	int t;
	scanf("%d",&t);
	for(int i=0;i<t;i++){
		int n;
		scanf("%d",&n);
		if(n%3==0)printf("%lld\n",1ll*n*n*n/27);
		else if(n%4==0)printf("%lld\n",1ll*n*n*n/32);
		else puts("-1");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值