zoj 1610 Count the Colors (线段树区间覆盖)

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input


The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.



Output


Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input


5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


<b< dd="">

Sample Output


1 1
2 1
3 1

1 1

0 2
1 1



题意:

在长度8000的一条线段上染色,后面染上的颜色会把先前的覆盖,求染完色之后,每颜色分别存在几段。

在输入区间长度的时候,令左端点加一,这样就可以把区间看成是不连续的点。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mx = 8100;
int node[4 * mx],num[mx],last;
void pushdown(int rt){
	if(node[rt] != -1){
		node[2 * rt] = node[2 * rt + 1] = node [rt];
		node[rt] = -1;
		return ;
	}
}
void update(int st, int en, int p, int l, int r, int rt){
	if(st <= l && r <= en){
		node[rt] = p;
		return;
	}
	pushdown(rt);
	int m = (l + r) / 2;
	if(st <= m) update(st, en, p, l, m, 2 * rt);
	if(m < en) update(st, en, p, m + 1, r, 2 * rt + 1);
}
void query(int l, int r, int rt){
	if(l == r){ 
		if(node[rt] != -1 && node[rt] != last)
			num[node[rt]]++;
				
		last = node[rt];
		return ;
	} 
	pushdown(rt);
	int m =(l + r) / 2;
	query(l, m, 2 * rt);
	query(m+1, r, 2 * rt + 1);
}
int main(){
	int n;
	while(scanf("%d", &n) != EOF){
		memset(num, 0, sizeof(num));
		memset(node, -1, sizeof(node)); 
		last = -1;
		int a, b, c;
		while(n--){
			scanf("%d%d%d", &a, &b, &c);
			if(a < b) update(a + 1, b, c, 1, 8000, 1);
		}
		query(1, 8000, 1);
		for(int i = 0; i < mx; i++){
			if(num[i]) printf("%d %d\n", i, num[i]);
		}
		puts("");
	}
	
	return 0;
} 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Blaze Jack

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值