HDOJ 5547 Sudoku(dfs)

Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller. 

Actually, Yi Sima was playing it different. First of all, he tried to generate a  4×4 4×4board with every row contains 1 to 4, every column contains 1 to 4. Also he made sure that if we cut the board into four  2×2 2×2 pieces, every piece contains 1 to 4. 

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover. 

Actually, you are seeing this because you've passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!
Input
The first line of the input gives the number of test cases,  T(1T100) T(1≤T≤100) T T test cases follow. Each test case starts with an empty line followed by 4 lines. Each line consist of 4 characters. Each character represents the number in the corresponding cell (one of '1', '2', '3', '4'). '*' represents that number was removed by Yi Sima. 

It's guaranteed that there will be exactly one way to recover the board.
Output
For each test case, output one line containing  Case #x:, where  x x is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.
Sample Input
3
****
2341
4123
3214
*243
*312
*421
*134
*41*
**3*
2*41
4*2*
Sample Output
Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123

数独模板留着以后用

#include<iostream>
#include<cstdio>
using  namespace std;
char str[5][5];
int num[4][4];
bool flag;
bool check(int n, int key){
	int x = n / 4, y = n % 4;
	for(int i = 0; i < 4; i++){
		if(num[x][i]==key || num[i][y]==key)
		return false;
	} 
	int x2 = x / 2 * 2, y2 = y / 2 * 2;
	for(int i = 0; i < 2; i++)
	  for(int j = 0; j < 2; j++)
	     if(num[x2+i][y2+j] == key)
	         return false;
	
	return true;
}
void dfs(int n){
	int x = n / 4, y = n % 4;
	if(n>15){
	  flag = true;
	  return;
	}
	if(num[x][y] != 0)
	  dfs(n+1);
	else{
		for(int i=1; i<=4; i++){
			if(check(n, i)){
	        	num[x][y] = i;
			    dfs(n+1);
				if(flag == true)
				    return;
				num[x][y] = 0;
			}
		}
	}
	
}

int main(){
	int T;
	scanf("%d",&T);
	for(int ca = 1; ca <= T; ca++){
		flag = false;
		for(int i = 0; i < 4; i++)
		   scanf("%s", str[i]);
		   
		for(int i = 0; i < 4; i++)
		  for(int j = 0; j < 4; j++)
		      if(str[i][j] =='*') 
			      num[i][j] = 0;
			  else
			      num[i][j] = str[i][j] - '0';
			      
		/*for(int i = 0; i < 4; i++){
	     for(int j = 0; j < 4; j++)
	    printf("%d", num[i][j]);
	    puts("");
			}
		*/
			
		dfs(0);
		printf("Case #%d:\n", ca);
		for(int i = 0; i < 4; i++){
		 for(int j = 0; j < 4; j++)
		    printf("%d", num[i][j]);
		    puts("");
		}	
	 }	
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Blaze Jack

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值