Jobdu1448 Legal or Not (拓扑排序)

Jobdu1448 Legal or Not (拓扑排序)
题目描述:
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.
输入:
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0.TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.
输出:
For each test case, print in one line the judgement of the messy relationship.If it is legal, output “YES”, otherwise “NO”.
样例输入:
3 2
0 1
1 2
2 2
0 1
1 0
0 0
样例输出:
YES
NO

很明显这是一道判断是不是能够成有向无环图(DAG),自然地想到拓扑排序。
2019年3月21日

#include<bits/stdc++.h>
#define inf 0x3f3f3f
#define maxn 10010
using namespace std;
typedef long long ll;
vector<int> e[maxn];
queue<int> que;
int inDegree[maxn]; //记录每个结点的入度
int cnt=0,n,m;
void topo(){
    while(!que.empty()) que.pop();
    //结点为0的入队
    for(int i=0;i<n;i++){
        if(!inDegree[i]){que.push(i);}
    }
    cnt=0;
    while(!que.empty()){
        int q1,q2,q3;
        q1=que.front();
        que.pop();
        cnt++;
        for(int i=0;i<e[q1].size();i++){
            inDegree[e[q1][i]]--;
            if(!inDegree[e[q1][i]]){
                que.push(e[q1][i]);
            }
        }
    }
    if(cnt==n) cout<<"YES"<<endl;
    else cout<<"NO"<<endl;
}
int main(){
    std::ios::sync_with_stdio(false);
    while(cin>>n>>m){
        if(n==0&&m==0) break;
        for(int i=0;i<n;i++){
            inDegree[i]=0;
            e[i].clear();
        }
        for(int i=0;i<m;i++){
            int x,y;
            cin>>x>>y;
            inDegree[y]++;
            e[x].push_back(y);
        }
        topo();

    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值