Exponentiation 【java 处理高精度】

Exponentiation

Time Limit: 2000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9530 Accepted Submission(s): 2827

Problem Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don’t print the decimal point if the result is an integer.

Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

Source
East Central North America 1988

注意 这里面的 将前导0去除的意思是 比如 0.011 你需要打印 .011 即小数点前的0都是前导0;

AC代码

import java.util.Scanner;
import java.math.BigInteger;
import java.math.BigDecimal;
import java.text.DecimalFormat;

 class Main {
    public static  void main(String[] args){
        Scanner cin = new Scanner(System.in);
        BigDecimal a;int b;
        while(cin.hasNext()){
            a=cin.nextBigDecimal();
            b=cin.nextInt();
            a=a.pow(b);
            String s=a.stripTrailingZeros().toPlainString();
            if(s.charAt(0)=='0') s=s.substring(1);
            System.out.println(s);
        }
    }
}

代码中用到了 两个函数
1 s.charAt(num) 这个就是索引这个字符串数组,和s[num]的性质是一样的。【不过必须要用那种形式】
2 s.substring() .
其中传递参数的方式有两种

import java.util.Scanner;
import java.math.BigInteger;
import java.math.BigDecimal;
import java.text.DecimalFormat;

 class Main {
    public static  void main(String[] args){
        Scanner cin = new Scanner(System.in);
        String s=new String("0123456");
        s=s.substring(1);
        System.out.println(s);//输出123456

        String str=new String("0123456");
        str=str.substring(3);
        System.out.println(str);//输出3456

        String ss=new String("0123456");
        ss=ss.substring(0,3);
         System.out.println(ss);//输出012

        String sss=new String("0123456");
        sss=sss.substring(0,5);
         System.out.println(sss);//输出01234
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值