【poj 3061】Subsequence 【尺取法】or【前缀和+二分】

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

代码

尺取法,时间复杂度o(n)

#include<cstdio>
#include<iostream>
using namespace std;
#define LL long long 
const int MAXN =1e5+10;
const int MAXM =1e4;
const int inf = 0x3f3f3f3f;
/*---------------------*/

int arr[MAXN];
int main(){
    int t;cin>>t;
    while(t--){
        int N,S;cin>>N>>S;
        for(int i=0;i<N;i++)
            scanf("%d",&arr[i]);
        int le,ri;
        le=ri=0;int sum=0;int cnt=inf;
        while(1){
            if(sum<S){
                if(ri==N) break;
                sum+=arr[ri];  
                ri++;
             }else if(sum>=S){
                if(le==ri) break;
                 cnt=min(cnt,ri-le);
                 sum-=arr[le];le++;
             }
         }

         printf("%d\n",cnt==inf?0:cnt);
     }
    return 0;
}

还有一种
我们可以先打个前缀和,然后每个区间的值都可以用arr[ri]-arr[le] 这样得到, (因为要求arr[ri]-arr[le]>=S) 所以我们可以枚举起点,用二分找到第一个大于等于S-arr[le]的标号,然后求解。 时间复杂度 o(nlogn)

代码

#include<cstdio>
#include<iostream>
#include<algorithm> 
#include<cmath>
using namespace std;
#define LL long long 
const int MAXN =1e5+10;
const int MAXM =1e4;
const int inf = 0x3f3f3f3f;
/*---------------------*/
int N,S;
int arr[MAXN];
int pre[MAXN];
void dabiao(){
    pre[0]=arr[0];
    for(int i=1;i<N;i++){
        pre[i]=pre[i-1]+arr[i];
    }
}
int main(){
    int t;cin>>t;
    while(t--){
    cin>>N>>S;
        for(int i=0;i<N;i++)
            scanf("%d",&arr[i]);
        dabiao();
        int cnt=inf;
        for(int i=0;i<N;i++){
            int x=lower_bound(pre,pre+N,S+pre[i])-pre;
            if(x>=N) break;// 没有满足条件的
            cnt=min(cnt,x-i);   
        }
        printf("%d\n",cnt==inf?0:cnt);
     }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值