【POJ - 2528】Mayor's posters 【离散化+线段树 】

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,… , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.
这里写图片描述
The picture below illustrates the case of the sample input.

Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4

题意 :x正半轴上,每次给一个区域染色,后来的颜色会覆盖先前的颜色,问n次染色后,能够看到的颜色有几种?

分析 :水题。。 首先区间范围太大,离散化是一定要用的,然后我可以用线段树来执行区间修改操作,最后再遍历所有的点,看有多少个不同的颜色.
代码

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<map>
#include<iostream>
using namespace std;
typedef pair<int,int>pii;
#define first fi
#define second se
#define  LL long long
#define fread() freopen("in.txt","r",stdin)
#define fwrite() freopen("out.txt","w",stdout)
#define CLOSE() ios_base::sync_with_stdio(false)

const int MAXN = 1e5;
const int MAXM = 1e6;
const int mod = 1e9+7;
const int inf = 0x3f3f3f3f;
struct Tree{
    int l,r,len;
    int lazy,val;  // val 代表染的颜色 
}tree[MAXN<<2];

void Build(int o,int le,int ri){
    tree[o].l=le,tree[o].r=ri;
    tree[o].lazy=tree[o].val=0;
    if(le==ri) return ;
    int mid=(le+ri)>>1; 
    Build(o<<1,le,mid);
    Build(o<<1|1,mid+1,ri);
}

void Down(int o){
    if(tree[o].lazy){
        tree[o<<1].lazy=tree[o<<1|1].lazy=tree[o].lazy;
        tree[o<<1].val=tree[o<<1|1].val=tree[o].lazy;
        tree[o].lazy=0;
    }
}

void Update(int o,int le,int ri,int val){
    if(tree[o].l>=le&&tree[o].r<=ri) {
        tree[o].val=val;
        tree[o].lazy=val;
        return ;
    }
    Down(o);
    int mid=(tree[o].l+tree[o].r)>>1;
    if(ri<=mid) Update(o<<1,le,ri,val);
    else if(le>mid) Update(o<<1|1,le,ri,val);
    else {
        Update(o<<1,le,mid,val);
        Update(o<<1|1,mid+1,ri,val);
    }
}
map<int,bool>vis;
void Query(int o){  // 遍历所有的 子叶节点
    if(tree[o].l==tree[o].r) {
        if(tree[o].val)  // 必须有颜色 
        vis[tree[o].val]=1; 
        return ;
    }
    Down(o);
    Query(o<<1);
    Query(o<<1|1); 
}

int X[MAXN],size;
int le[MAXN],ri[MAXN];
int main(){
    CLOSE();
//  fread();
//  fwrite();
    int t;scanf("%d",&t);
    while(t--){
        vis.clear();
        int n;scanf("%d",&n);size=0; 
        for(int i=1;i<=n;i++){
            scanf("%d%d",&le[i],&ri[i]);
            X[size++]=le[i];X[size++]=ri[i];
        }
        sort(X,X+size); size=unique(X,X+size)-X;
        Build(1,1,size);
        for(int i=1;i<=n;i++){
            int l=lower_bound(X,X+size,le[i])-X+1;
            int r=lower_bound(X,X+size,ri[i])-X+1;
            Update(1,l,r,i); //区间更新 
        }
        Query(1);
        printf("%d\n",vis.size());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值