【LightOJ - 1007】Mathematically Hard 【欧拉函数筛】

Mathematically some problems look hard. But with the help of the computer, some problems can be easily solvable.

In this problem, you will be given two integers a and b. You have to find the summation of the scores of the numbers from a to b (inclusive). The score of a number is defined as the following function.

score (x) = n2, where n is the number of relatively prime numbers with x, which are smaller than x

For example,

For 6, the relatively prime numbers with 6 are 1 and 5. So, score (6) = 22 = 4.

For 8, the relatively prime numbers with 8 are 1, 3, 5 and 7. So, score (8) = 42 = 16.

Now you have to solve this task.

Input
Input starts with an integer T (≤ 105), denoting the number of test cases.

Each case will contain two integers a and b (2 ≤ a ≤ b ≤ 5 * 106).

Output
For each case, print the case number and the summation of all the scores from a to b.

Sample Input
3
6 6
8 8
2 20
Sample Output
Case 1: 4
Case 2: 16
Case 3: 1237

分析:思路很明确, 但是过程艰辛啊,一开始用o(n)的筛,超内存,然后用欧拉函数筛,又暴LL,但是ULL好像正好够,-_-|| 。
代码

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define ULL unsigned long long

const int N  = 5e6+11;
const int M  = 1e6+11;
const int mod = 1e9+7;
const int inf = 0x3f3f3f3f;

int phi[N+1]; ULL sum[N+1];
void init(){
    phi[1]=1;
    for(int i=2;i<N;i++){
        if(!phi[i]){
            for(int j=i;j<N;j+=i){
                if(!phi[j]) phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
        }
    }
    for(int i=1;i<N;i++){
        sum[i]=sum[i-1]+phi[i]*1ll*phi[i];
    }
    //cout<<sum[N-1];
}

int main(){
    init();
    int T ;scanf("%d",&T);
    int cas=1;
    while(T--){
        int a,b; scanf("%d%d",&a,&b);
        printf("Case %d: %llu\n",cas++,sum[b]-sum[a-1]);
    }
return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值