HDU_【2017 Multi-University Training Contest 2】——1011 Regular polygon

题目链接

Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
Output
For each case, output a number means how many different regular polygon these points can make.
Sample Input
4
0 0
0 1
1 0
1 1
6
0 0
0 1
1 0
1 1
2 0
2 1
Sample Output
1
2
题目意思
给你n个点,接着给你这n个点的坐标,求这些点能组成多少个正多边形。
解题思路
因为都是整数点,所以可以知道这些点只能组成正四边形。所以我们将这些点按照横纵坐标排序,然后枚举两个点,暴力找另外两个点的位置是否存在就行。
代码部分
#include <bits/stdc++.h>
using namespace std;
const int maxn=510;
struct Node///将横坐标和纵坐标按照从小到大的顺序排序
{
    int x,y;
    bool operator<(const Node& rhs)const
    {
        if(x == rhs.x)
            return y < rhs.y;
        else
            return x < rhs.x;
    }
} nodes[maxn];

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int ans=0;///正方形个数
        for(int i=0; i<n; ++i)
            scanf("%d%d",&nodes[i].x,&nodes[i].y);
        sort(nodes,nodes+n);
        for(int i=0; i<n; ++i)
            for(int j=i+1; j<n; ++j)
            {
                ///看一下以i,j两个点作为正方形得一条边能不能找到其余的两个顶点
                Node tmp;//tmp作为正方形的第3或4个点
                tmp.x=nodes[i].x+nodes[i].y-nodes[j].y;

                tmp.y=nodes[i].y+nodes[j].x-nodes[i].x;

                if(!binary_search(nodes,nodes+n,tmp)) 
                    continue;
                tmp.x=nodes[j].x+nodes[i].y-nodes[j].y;

                tmp.y=nodes[j].y+nodes[j].x-nodes[i].x;

                if(!binary_search(nodes,nodes+n,tmp))
                 continue;
                ///只有两个点都找到才能够构成一个正方形
                ++ans;
            }
        printf("%d\n",ans/2);///注意这里/2,原因是因为一个正方形可以通过最最左下角得那个点向上和向右分别找到同一个正方形两次
    }
    return 0;
}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值