2017多校训练第二场 hdu6045 Is Derek lying

Is Derek lying

Time Limit: 3000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)

Problem Description
Derek and Alfia are good friends. Derek is Chinese, and Alfia is Austrian. This summer holiday, they both participate in the summer camp of Borussia Dortmund. During the summer camp, there will be fan tests at intervals. The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”. Each question has only one correct answer and each question is worth 1point.It means that if your answer for this question is right, you can get 1point.The total score of a person is the sum of marks for all questions. When the test is over, the computer will tell Derek the total score of him and Alfia. Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X, your total score is Y.”But Derekis naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made, you should judge whether Derek is lying. If there exists a set of standard answer satisfy the total score that Derek said, you can consider he is not lying, otherwise he is lying.

Input
The first line consists of an integer T, represents the number of test cases.
For each test case, there will be three lines.
The first line consists of three integers N, X, Y, the meaning is mentioned above.
The second line consists of N characters, each character is “A” “B”or“C”, which represents the answer of Derek for each question.
The third line consists of Ncharacters, the same form as the second line, which represents the answer of Alfia for each question.

Data Range:
1≤N≤80000, 0≤X,Y≤N,∑Ti=1N≤300000

Output
For each test case,the output will be only a line.
Please print “Lying” if you can make sure that Derekis lying,otherwise please print “Not lying”.

Sample Input
2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

Sample Output
Not lying
Lying

Source
http://acm.hdu.edu.cn/showproblem.php?pid=6045

理解样例:
2(T)个测试样例,
第一个测试样例:
第一行:有5个问题(N),5种答案按照ABCD的字母顺序排下去,Derek得分1(X)分,Alfia得分3(Y)分
第二行: Derek的答案
第三行:Alfia的答案
分析:这种情况是可能成立的,即正确答案是ABC时,得分为1 3,所以输出”Not lying

算法:这是本场的签到题,算法也是非常简单,发现其实最后的得分范围之与两人答题相同与不同的数量有关。计算出两人答题相同的数量为same,不同的数量为different,那么,两人的分数一定是由共同的部分都拿了x分(x∈(0,same))+各自拿的y1,y2分(这里的y必须满足(0<=y1+y2<=different),相当于它们各自在这些题里拿了一部分分数),那么根据这两点,我们只需要设好它们分数的范围,看看Derek给出的分数是否合法就可以了。

AC代码:

#include  <iostream>
#include  <stdio.h>
#include  <algorithm>
#include  <iomanip>
#include  <vector>
#include  <queue>
#include  <map>
#include  <cstring>
#include  <string>
#include  <cctype>
#include  <cmath>
typedef long long LL;
using namespace std;
char f[80005];

int main()
{
    ios_base::sync_with_stdio(false); cin.tie(0);
    int T,n,a,b,sa,di,ok;
    char tmp;
    cin>>T;
    while(T--)
    {
        cin>>n>>a>>b;
        sa=0;di=0;ok=1;
        for(int i=0;i<n;i++) cin>>f[i];
        for(int i=0;i<n;i++)
        {
            cin>>tmp;
            if(f[i]!=tmp) di++;
            else sa++;
        }
        if(a>n || b>n) ok=0;//个人成绩要合法
        if(2*sa+di<a+b) ok=0;//两人分数总和不能超过所有题目都对的上限
        if(abs(a-b)>di) ok=0;//两个人分差不可能大于答案不同的题目数量
        if(ok==1) cout<<"Not lying"<<endl;
        else cout<<"Lying"<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值