HDU 6143

Killer Names

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1745    Accepted Submission(s): 857


Problem Description
> Galen Marek, codenamed Starkiller, was a male Human apprentice of the Sith Lord Darth Vader. A powerful Force-user who lived during the era of the Galactic Empire, Marek originated from the Wookiee home planet of Kashyyyk as the sole offspring of two Jedi Knights—Mallie and Kento Marek—who deserted the Jedi Order during the Clone Wars. Following the death of his mother, the young Marek's father was killed in battle by Darth Vader. Though only a child, Marek possessed an exceptionally strong connection to the Force that the Dark Lord of the Sith sought to exploit.
>
> When Marek died in 2 BBY, shortly after the formation of the Alliance, Vader endeavored to recreate his disciple by utilizing the cloning technologies of the planet Kamino. The accelerated cloning process—an enhanced version of the Kaminoan method which allowed for a rapid growth rate within its subjects—was initially imperfect and many clones were too unstable to take Marek's place as the Dark Lord's new apprentice. After months of failure, one particular clone impressed Vader enough for him to hope that this version might become the first success. But as with the others, he inherited Marek's power and skills at the cost of receiving his emotions as well, a side effect of memory flashes used in the training process.
>
> — Wookieepedia

Darth Vader is finally able to stably clone the most powerful soilder in the galaxy: the Starkiller. It is the time of the final strike to destroy the Jedi remnants hidden in every corner of the galaxy.

However, as the clone army is growing, giving them names becomes a trouble. A clone of Starkiller will be given a two-word name, a first name and a last name. Both the first name and the last name have exactly n characters, while each character is chosen from an alphabet of size m. It appears that there are m2n possible names to be used.

Though the clone process succeeded, the moods of Starkiller clones seem not quite stable. Once an unsatisfactory name is given, a clone will become unstable and will try to fight against his own master. A name is safe if and only if no character appears in both the first name and the last name.

Since no two clones can share a name, Darth Vader would like to know the maximum number of clones he is able to create.
 

Input
The First line of the input contains an integer T ( T10), denoting the number of test cases.

Each test case contains two integers n and m ( 1n,m2000).
 

Output
For each test case, output one line containing the maximum number of clones Vader can create.

Output the answer  mod 109+7
 

Sample Input
 
 
2 3 2 2 3
 

Sample Output
 
 
2 18
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6297  6296  6295  6294  6293 
 
#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define maxn 2010
#define ll long long
#define INF 10000000
using namespace std;
const int mod=1e9+7;
long long  dp[maxn][maxn],n,m;
long long Q_pow(long long x,long long p)//快速幂模板
{
    long long ans=1;
    while(p)
    {
        if(p&1) ans=ans*x%mod;
        p>>=1;
        x=x*x%mod;
    }
    return ans%mod;
}
/*
dp[i][j]表示长度为i用j种颜色填充,
总共可填充的颜色不超过m种,
那么,dp存在递推关系,
长度如果为i-1,那么有两种情况,
已填充j种颜色,此时只要从j中再选一种,
已填充j-1种颜色,此时只要从剩余的m-j+1种颜色中再选一种。
这样递推关系就构成了


下面分析乘法关系,
后面的快速幂得到的结果是剩余m-i种颜色可选的构成的选择数,
这和前面的已选j种不同,
当前面的已经选了j种情况确定时,后面的是剩余可选的情况。
即先选,后剩余可选,枚举先选的,构成全部情况。

*/
void _table()
{
    dp[1][1]=m;
    for(int i=2;i<=n;i++)
        for(int j=1;j<=i&&j<=m;j++)
           dp[i][j]=( dp[i-1][j]*j%mod+dp[i-1][j-1]*(m-j+1)%mod ) % mod;
}
int main()
{
    int t;cin>>t;
    while(t--)
    {
        cin>>n>>m;
            _table();
        long long ans=0;
        for(int i=1;i<m;i++)
            ans=(ans+dp[n][i]*Q_pow(m-i,n)%mod)%mod;
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值