Given two arrays A and B, we can determine the array C = A B using the standard definition of matrix multiplication:
The number of columns in the A array must be the same as the number of rows in the B array. Notationally, let's say that rows(A) and columns(A) are the number of rows and columns, respectively, in the A array. The number of individual multiplications required to compute the entire C array (which will have the same number of rows as A and the same number of columns as B) is then rows(A) columns(B) columns(A). For example, if A is a 10 x 20 array, and B is a 20 x 15 array, it will take 10 x 15 x 20, or 3000 multiplications to compute the C array.
To perform multiplication of more than two arrays we have a choice of how to proceed. For example, if X, Y, and Z are arrays, then to compute X Y Z we could either compute (X Y) Z or X (Y Z). Suppose X is a 5 x 10 array, Y is a 10 x 20 array, and Z is a 20 x 35 array. Let's look at the number of multiplications required to compute the product using the two different sequences:
(X Y) Z
5 x 20 x 10 = 1000 multiplications to determine the product (X Y), a 5 x 20 array.
Then 5 x 35 x 20 = 3500 multiplications to determine the final result.
Total multiplications: 4500.
X (Y Z)
10 x 35 x 20 = 7000 multiplications to determine the product (Y Z), a 10 x 35 array.
Then 5 x 35 x 10 = 1750 multiplications to determine the final result.
Total multiplications: 8750.
Clearly we'll be able to compute (X Y) Z using fewer individual multiplications.
Given the size of each array in a sequence of arrays to be multiplied, you are to determine an optimal computational sequence. Optimality, for this problem, is relative to the number of individual multiplcations required.
Input
For each array in the multiple sequences of arrays to be multiplied you will be given only the dimensions of the array. Each sequence will consist of an integer N which indicates the number of arrays to be multiplied, and then N pairs of integers, each pair giving the number of rows and columns in an array; the order in which the dimensions are given is the same as the order in which the arrays are to be multiplied. A value of zero for N indicates the end of the input. N will be no larger than 10.
Output
Assume the arrays are named A1, A2, ..., AN. Your output for each input case is to be a line containing a parenthesized expression clearly indicating the order in which the arrays are to be multiplied. Prefix the output for each case with the case number (they are sequentially numbered, starting with 1). Your output should strongly resemble that shown in the samples shown below. If, by chance, there are multiple correct sequences, any of these will be accepted as a valid answer.
Sample Input
1 5
5 20
20 1
3
5 10
10 20
20 35
6
30 35
35 15
15 5
5 10
10 20
20 25
0
Sample Output
Case 1: (A1 x (A2 x A3))
Case 2: ((A1 x A2) x A3)
Case 3: ((A1 x (A2 x A3)) x ((A4 x A5) x A6))
#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define mod 1e9+7
#define ll long long
#define maxn 101
#define MAX 1000000000
using namespace std;
int p[maxn];
int x,y,dp[maxn][maxn];
/*
题目大意:给定n个矩阵其维度,
不仅要找出矩阵练连乘的最优方案,
还要打印路径。
最优化方案太模板了,
就是普通的连乘模板,
打印路径的话要分析打印的子结构,
该题的打印要找出原子结构是什么,
这题原子结构是单个的矩阵符号,
两个原子结构相乘,原子结构里面还嵌套着原子结构。
对于递归的条件,根据dp数组的产生而观察得到
*/
void print(int l,int r)
{
if(r-l<1) return ;
if(r-l==1)
{
printf("A%d",l+1);
return ;
}
int k;
for(int i=l+1;i<r;i++)
{
if(dp[l][i]+dp[i][r]+p[l]*p[i]*p[r]==dp[l][r])
{
k=i;
break;
}
}
printf("(");
print(l,k);
printf(" x ");
print(k,r);
printf(")");
}
int main()
{
int n,cnt=0;
while( scanf("%d",&n)!=EOF && n)
{
int i;
for(i=0;i<n;i++)
{
scanf("%d%d",&x,&y);
p[i]=x , dp[i][i]=dp[i][i+1]=0;
}
p[i]=y , dp[i][i]=dp[i][i+1]=0;
for(int t=2;t<=n;t++)
{
for( int j=0;j<=n;j++)
{
if(t+j>n) break;
dp[j][j+t]=MAX; ///设为无限大值
for( int q=j+1;q<j+t;q++)
dp[j][j+t]=min( dp[j][j+t] , dp[j][q]+dp[q][j+t]+p[j]*p[q]*p[j+t]);
}
}
printf("Case %d: ",++cnt);
print(0,n); puts("");
}
return 0;
}