HDU 6336 Problem E. Matrix from Arrays (数学规律)

Problem E. Matrix from Arrays

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1372    Accepted Submission(s): 623


 

Problem Description

Kazari has an array A length of L , she plans to generate an infinite matrix M using A .
The procedure is given below in C/C++:

int cursor = 0;
for (int i = 0; ; ++i) {
    for (int j = 0; j <= i; ++j) { 
        M[j][i - j] = A[cursor];
        cursor = (cursor + 1) % L;
    }
}


Her friends don't believe that she has the ability to generate such a huge matrix, so they come up with a lot of queries about M , each of which focus the sum over some sub matrix. Kazari hates to spend time on these boring queries. She asks you, an excellent coder, to help her solve these queries.

 

 

Input

The first line of the input contains an integer T (1≤T≤100) denoting the number of test cases.
Each test case starts with an integer L (1≤L≤10) denoting the length of A .
The second line contains L integers A0,A1,...,AL−1 (1≤Ai≤100) .
The third line contains an integer Q (1≤Q≤100) denoting the number of queries.
Each of next Q lines consists of four integers x0,y0,x1,y1 (0≤x0≤x1≤108,0≤y0≤y1≤108) querying the sum over the sub matrix whose upper-leftmost cell is (x0,y0) and lower-rightest cell is (x1,y1) .

 

 

Output

For each test case, print an integer representing the sum over the specific sub matrix for each query.

 

 

Sample Input

 

1 3 1 10 100 5 3 3 3 3 2 3 3 3 2 3 5 8 5 1 10 10 9 99 999 1000

 

 

Sample Output

 

1 101 1068 2238 33076541

 

 

Source

2018 Multi-University Training Contest 4

 

 

Recommend

chendu   |   We have carefully selected several similar problems for you:  6373 6372 6371 6370 6369 

 

#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<queue>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define mod 1e9+7
#define ll unsigned long long
#define MAX 1000000000
#define ms memset
#define maxn 50
using namespace std;

int l,q,m;
int x1,y1,x2,y2;
int tb[maxn];

int mp[maxn][maxn],ub;
ll ans=0;
/*
题目大意:给定矩阵的生成方式,
然后有q个查询,求其查询的子矩阵的值和。

先打表找到循环节,(看 数字观察),
是以2l为周期。

容斥定理,对于一个xy轴坐标值,
在图纸上画图不难观察到,其中的求值规律,
附加简单的容斥定理即可。

而对于单个的求二维前缀和,
数学规律见封装的函数代码。

*/

ll compute(ll x,ll y)
{
    ll ret=0;
    ll tx=x/ub,ty=y/ub;
    ret+=mp[x%ub][y%ub];
    ret+=(tx)*mp[ub][y%ub];
    ret+=(ty)*mp[x%ub][ub];
    ret+=tx*ty*mp[ub][ub];
    return ret;
}

int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&l);
        for(int i=0;i<l;i++) scanf("%d",&tb[i]);

        ///ub=((l&1)?l:2*l);
        ub=2*l;

        memset(mp,0,sizeof(mp));

        for(int i=0;i<ub;i++)
            for(int j=0;j<ub;j++)
            {
                int t=i+j;
                t=t*(t+1)/2+i;
                t%=l;

                mp[i+1][j+1]=tb[t];
            }

        for(int i=1;i<=ub;i++)
            for(int j=1;j<=ub;j++)
            {
                 mp[i][j]+=(mp[i-1][j]+mp[i][j-1]);
                 mp[i][j]-=mp[i-1][j-1];
            }


            /*
        for(int i=1;i<=ub;i++)
        {
            for(int j=1;j<=ub;j++)   cout<<mp[i][j]<<" ";
             puts("");
        }*/

       ///cout<<compute(8,5)<<endl;///<<" "<<compute(3,1)*3<<" "<<compute(1,3)*3<<" "<<9*compute(3,3)<<endl;

        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            ans=0;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            x2++,y2++;
            ans+=compute(x2,y2);
            ans+=compute(x1,y1);
            ans-=compute(x2,y1);
            ans-=compute(x1,y2);
            printf("%lld\n",ans);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值