SDUT-->1832 Sorting It All Out

Sorting It All Out

Time Limit: 1000MS  Memory Limit: 10000KB
Problem Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Example Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Example Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题目样例的三种输出分别是:

1. 在第x个关系中可以唯一的确定排序,并输出。

2. 在第x个关系中发现了有回环(Inconsisitency矛盾)

3.全部关系都没有发现上面两种情况,输出第3种.

题目大意:
多组输入,每行两个数N,M,N代表节点的数目,M代表边的数目,每行三个字符a<c,让你判断能否构建成一个拓扑序列,对应输出。
知识点:
拓扑序列的判定

对于给定的m个关系,一个个的读进去,每读进去一次就要进行一次拓扑排序,如果发现情况1和情况2,那么就不用再考虑后面的那些关系了,但是还要继续读完后面的关系(但不处理)。如果读完了所有关系,还没有出现情况1和情况2,那么就输出情况3.

拓扑排序用贪心的思想:

1. 找到所有入度为0的点, 加入队列Q

2.取出队列Q的一个点,把以这个点为起点,所有它的终点的入度都减1. 如果这个过程中发现经过减1后入度变为0的,把这个点加入队列Q。

3.重复步骤2,直到Q为空。


这个过程中,如果同时有多个点的入度为0,说明不能唯一确定关系。

如果结束之后,所得到的经过排序的点少于点的总数,那么说明有回环。



题目还需要注意的一点:如果边(u,v)之前已经输入过了,那么之后这条边都不再加入。


AC代码:
# include <bits/stdc++.h>
using namespace std;
const int MAXN=1e2;
int N, M, sum;
int in[MAXN], step[MAXN];///in数组记录入度,step记录路径
vector<int>z[MAXN];///用vector模拟邻接表存数据
void start()
{
    memset(in,0,sizeof(in));
    for(int i=0; i<=N; i++)
        z[i].clear();
}
bool Find(int a, int b)
{
    for(int i=0; i<z[a].size(); i++)
    {
        if(z[a][i]==b)
            return true;
    }
    return false;
}
int zhao()
{
    queue<int>Q;
    sum=0;
    for(int i=0; i<N; i++)
    {
        if(in[i]==0)
            Q.push(i);
    }
    int fly=false;
    while(!Q.empty())
    {
        if(Q.size()>1)fly=true;///如果只存在一个入度为0的点,说明存在拓扑序列,反之则不构成
        int m=Q.front();
        Q.pop();
        step[sum++]=m;
        for(int i=0; i<z[m].size(); i++)
        {
            in[z[m][i]]--;
            if(in[z[m][i]]==0)///借助队列降低时间复杂度
                Q.push(z[m][i]);
        }
    }
    if(sum<N)///存在回路
        return 2;
    if(fly)return 3;
    return 1;
}
int main()
{
    while(cin>>N>>M&&N&&M)
    {
        start();
        char aa, bb, cc;
        int flag=3;
        int stop;
        for(int t=1; t<=M; t++)
        {
            cin>>aa>>bb>>cc;
            if(flag!=3)continue;
            int a=aa-'A', c=cc-'A';
            if(!Find(a,c))///判断之前是否已经存过此边
            {
                z[a].push_back(c);
                in[c]++;
            }
            int temp[MAXN];
            memcpy(temp,in,sizeof(in));
            flag=zhao();
            memcpy(in,temp,sizeof(temp));///还原in数组
            if(flag!=3)
                stop=t;
        }
        if(flag==1)
        {
            cout<<"Sorted sequence determined after "<<stop<<" relations: ";
            for(int i=0; i<sum; i++)
            {
                char p=step[i]+'A';
                cout<<p;
            }
            cout<<'.'<<endl;
        }
        else if(flag==2)
            cout<<"Inconsistency found after "<<stop<<" relations."<<endl;
        else
            cout<<"Sorted sequence cannot be determined."<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值