POJ 2738 Two Ends(记忆化搜索+dp)

97 篇文章 0 订阅
21 篇文章 0 订阅

In the two-player game "Two Ends", an even number of cards is laid out in a row. On each card, face up, is written a positive integer. Players take turns removing a card from either end of the row and placing the card in their pile. The player whose cards add up to the highest number wins the game. Now one strategy is to simply pick the card at the end that is the largest -- we'll call this the greedy strategy. However, this is not always optimal, as the following example shows: (The first player would win if she would first pick the 3 instead of the 4.) 
3 2 10 4 
You are to determine exactly how bad the greedy strategy is for different games when the second player uses it but the first player is free to use any strategy she wishes.
Input
There will be multiple test cases. Each test case will be contained on one line. Each line will start with an even integer n followed by n positive integers. A value of n = 0 indicates end of input. You may assume that n is no more than 1000. Furthermore, you may assume that the sum of the numbers in the list does not exceed 1,000,000.
Output
For each test case you should print one line of output of the form: 
In game m, the greedy strategy might lose by as many as p points. 
where m is the number of the game (starting at game 1) and p is the maximum possible difference between the first player's score and second player's score when the second player uses the greedy strategy. When employing the greedy strategy, always take the larger end. If there is a tie, remove the left end.
Sample Input
4 3 2 10 4
8 1 2 3 4 5 6 7 8
8 2 2 1 5 3 8 7 3
0
Sample Output
In game 1, the greedy strategy might lose by as many as 7 points.
In game 2, the greedy strategy might lose by as many as 4 points.
In game 3, the greedy strategy might lose by as many as 5 points.


题解:

题意:

两个人都从数列两边取数,第一个人吃了聪明豆,会为长远考虑,第二个人是脑残,只选两端大的,每个人每次结果累加,问他们的最大差值为多少

思路:

因为我不是我们队搞dp的,所以完全没有hhhhh,因为老赵一直在怼A题,我又把我该做的都做完了,所以我就硬着头皮上了,看了题解看懂了就照着打了一遍qwq

代码:

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<deque>
#define M (t[k].l+t[k].r)/2
#define lson k*2
#define rson k*2+1
#define ll long long
#define INF 100861111;
using namespace std;
int a[1005];
int dp[1005][1005],n;
int done(int x,int y)
{
    if(dp[x][y]!=-1)//如果已经有值了
        return dp[x][y];
    if(x+1==y)//如果选到了最后两个
        return dp[x][y]=abs(a[x]-a[y]);
    int sa,sb;
    if(a[x+1]>=a[y])//如果a取x处的情况
        sa=done(x+2,y)+a[x]-a[x+1];
    else
        sa=done(x+1,y-1)+a[x]-a[y];
    if(a[x]<a[y-1])//如果a取y处的情况
        sb=done(x,y-2)+a[y]-a[y-1];//递归+差值
    else
        sb=done(x+1,y-1)+a[y]-a[x];
    return dp[x][y]=max(sa,sb);//取最优
}
int main()
{
    int i,j=1;
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        memset(dp,-1,sizeof(dp));
        printf("In game %d, the greedy strategy might lose by as many as %d points.\n",j,done(0,n-1));
        j++;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值