HDU 3613 Best Reward(扩展KMP模板)

93 篇文章 1 订阅
16 篇文章 0 订阅

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v  1, v  2, ..., v  26 (-100 ≤ v  i≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v  1, the value of 'b' is v  2, ..., and so on. The length of the string is no more than 500000. 

Output
Output a single Integer: the maximum value General Li can get from the necklace.
Sample Input
2
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
aba
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
acacac
Sample Output
1
6

题解:

题意:

给你26个字母的值,再给一个字符串,问你把这个串串分成两半,如果分成的子串为回文串,串的值就是他里面的所有字母的和,如果不是就为0,要你输出可以得到的最大值

思路:

这题要用到扩展KMP。。完全不会,通过这题从别人的博客那里学习了模板,扩展KMP讲的就是求两个串的最长公共前缀长度,用一个extend数组保存,第i个表示主串第i个位置开始匹配的最长公共前缀长度。

这题思路就是现将给的字符串反转一下得到一个新的字符串,然后用s2作为主串用s1去匹配,得到一个数组ex1,再用s1作为主串匹配s2得到数组ex2,然后遍历所有可以拆分的位置,假设串长为len,如果i+ex1[i]==len就说明把字符串从第i个位置拆,左边部分0到len-i是一个回文串,就累加这一段的和,如果len-i+ex2[len-i]==len,则说明右边部分是一个回文串,累加右边的结果,最后取其中最大值就好了。

代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
#include<algorithm>
using namespace std;
#define lson k*2
#define rson k*2+1
#define M (t[k].l+t[k].r)/2
#define INF 100861111
#define ll long long
#define eps 1e-15
int Next[500005];
int ex1[500005];
int ex2[500005];
int sum[500005];
void EKMP(char s[],char t[],int Next[],int extend[])//s为主串,t为模板串
{
    int i,j,p,L;
    int lens=strlen(s);
    int lent=strlen(t);
    Next[0]=lent;
    j=0;
    while(j+1<lent && t[j]==t[j+1])j++;
    Next[1]=j;
    int a=1;
    for(i=2;i<lent;i++)
    {
        p=Next[a]+a-1;
        L=Next[i-a];
        if(i+L<p+1)Next[i]=L;
        else
        {
            j=max(0,p-i+1);
            while(i+j<lent&&t[i+j]==t[j])j++;
            Next[i]=j;
            a=i;
        }
    }
    j=0;
    while(j<lens&&j<lent&&s[j]==t[j])j++;
    extend[0]=j;
    a=0;
    for(i=1;i<lens;i++)
    {
        p=extend[a]+a-1;
        L=Next[i-a];
        if(L+i<p+1)extend[i]=L;
        else
        {
            j=max(0,p-i+1);
            while(i+j<lens&&j<lent&&s[i+j]==t[j])j++;
            extend[i]=j;
            a=i;
        }
    }
}
int main()
{
    int i,j,len,pos,t,maxx;
    int v[30];
    char s1[500005],s2[500005];
    scanf("%d",&t);
    while(t--)
    {
        for(i=0;i<26;i++)
            scanf("%d",&v[i]);
        scanf("%s",s1);
        sum[0]=0;
        len=strlen(s1);
        for(i=0,j=len-1;i<len;i++,j--)
        {
            s2[j]=s1[i];
            sum[i+1]=sum[i]+v[s1[i]-'a'];
        }
        s2[len]='\0';
        EKMP(s2,s1,Next,ex1);
        EKMP(s1,s2,Next,ex2);
        maxx=-1;
        for(i=1;i<len;i++)
        {
            int temp=0;
            if(i+ex1[i]==len)
            {
                temp+=sum[len-i];
            }
            pos=len-i;
            if(pos+ex2[pos]==len)
            {
                temp+=(sum[len]-sum[pos]);
            }
            if(maxx<temp)
                maxx=temp;
        }
        printf("%d\n",maxx);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值