POJ 1459 Power Network(最大流+dinic算法模板)

55 篇文章 0 订阅
7 篇文章 0 订阅

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p  max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c  max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l  max(u,v) of power delivered by u to v. Let Con=Σ  uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c  max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l  max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 
Input
There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l  max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p  max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c  max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output
For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4
Sample Output
15
6
Hint
The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

题解:

题意见我之前写这题的EK算法版的文章:http://blog.csdn.net/qq_37497322/article/details/77834456

又写一遍这题的目的:

因为之前用EK算法这题耗的时间有点多,然后看到紫书上说由于EK算法的复杂度比较高为o(m*2*n),一般不用该算法来算最大流,一般是用dinic算法和ISPA算法,这里用的是dinic算法。。网上找了个比较好的模板就套上去了,时间复杂度是o(n^2*m),会比EK算法快很多,这个用了200ms左右,邻接矩阵的EK算法用了600ms左右

也就是说dinic算法是EK算法的DFS优化版

代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
#include<algorithm>
using namespace std;
#define INF 100861111
#define ll long long
#define eps 1e-5
#define maxn 105
struct node
{
    int c;
    int f;
};
int sx,ex;//sx和ex分别代表源点和汇点
int pre[maxn];
node p[maxn][maxn];
int n,m;
bool BFS()//BFS搜索层次网络
{
     memset(pre,0,sizeof(pre));
    queue< int > q;
    q.push(sx);
    pre[sx]=1;
    while(!q.empty())
    {
        int d=q.front();
        q.pop();
        for(int i=0;i<n;i++)
        {
            if(!pre[i]&&p[d][i].c-p[d][i].f)
            {
                pre[i]=pre[d]+1;
                q.push(i);
            }
        }
    }
    return pre[ex]!=0;
}
int dinic(int pos,int flow)//pos是顶点号,flow是当前顶点所能得到的流量
{
    int f=flow;
    if(pos==ex)
    return flow;
    for(int i=0;i<n;i++)
    {
        if(p[pos][i].c-p[pos][i].f&&pre[pos]+1==pre[i])
        {
            int a=p[pos][i].c-p[pos][i].f;
            int t=dinic(i,min(a,flow));
            p[pos][i].f+=t;
            p[i][pos].f-=t;
            flow-=t;
        }
    }
    return f-flow;
}
int slove()
{
    int sum=0;
    while(BFS())
    {
        sum+=dinic(sx,INF);
    }
    return sum;
}
void scan_d(int &ret)
{
    char c;
    ret=0;
    while((c=getchar())<'0'||c>'9');
    while(c>='0'&&c<='9')
    {
        ret=ret*10+(c-'0'),c=getchar();
    }
}
int main()
{
    int i,j,x,y,c,num1,num2;
    while(scanf("%d%d%d%d",&n,&num1,&num2,&m)!=EOF)
    {
        memset(p,0,sizeof(p));
        for(i=0;i<m;i++)
        {
            scan_d(x);
            scan_d(y);
            scan_d(c);
            p[x][y].c=c;
        }
        sx=n;
        ex=n+1;
        n+=2;
        for(i=0;i<num1;i++)
        {
            scan_d(x);
            scan_d(y);
            p[sx][x].c=y;
        }
        for(i=0;i<num2;i++)
        {
            scan_d(x);
            scan_d(y);
            p[x][ex].c=y;
        }
        printf("%d\n",slove());
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值