03-树2 List Leaves(25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -

0 -
2 7

5 -
4 6
Sample Output:
4 1 5

思路:

以a存储输入,然后将a转化成b,b为树形结构,此处详解buildTree()函数
递归实现建树操作:如果左子树不为空,则建左子树,右子树同。为了方便的进行从上到下、从左到右的叶节点遍历,很明显应该使用层次遍历。数组b的元素顺序即为层次遍历顺序。层次遍历顺序用数组存储有如下特点:
1.若根节点下标以0开始:父亲节点下标为i时,则其左儿子的下标为2i+1,右儿子的下标为2i+2
2.若根节点下标以1开始:父亲节点下标为i时,则其左儿子的下标为2i,右儿子的下标为2i+1

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
using namespace std;

typedef struct Node{
	char left;
	char right;
	bool flag;//标记其是否为叶节点,是--1  不是--0 
}; 
typedef struct treeNode{
	int data;
	bool flag;//标记其是否为叶节点,是--1  不是--0 
};
void buildTree(treeNode b[], int i, Node a[], int root){
	b[i].data = root;
	b[i].flag = a[root].flag;
	
	if(b[i].flag == 1)
		return ;
	
	if(a[root].left != '-')
		buildTree(b,2*i+1,a,a[root].left-'0');
	if(a[root].right != '-')
		buildTree(b,2*i+2,a,a[root].right-'0');
}
int main(){
	Node a[10];//存储输入信息 
	treeNode b[100];//根据a建立树形结构 
	bool mark[10] = {0};//用来寻找根节点 

	//读取输入并找到树的根节点,依据为根节点不会被任何节点的指针所指向,即所有指针中没出现的下标为根节点下标
	int n;
	cin >> n;
	for(int i = 0; i < n; i++){
		cin >> a[i].left >> a[i].right;
		if(a[i].left == '-' && a[i].right == '-')
			a[i].flag = 1;
		else
			a[i].flag = 0;
			
		if(a[i].left != '-')
			mark[a[i].left - '0'] = 1;
		if(a[i].right != '-')
			mark[a[i].right - '0'] = 1; 
	}
	int root;
	for(int i = 0; i < n; i++){
		if(mark[i] == 0){
			root = i;
			break;
		}
	}
	
	//初始化
	for(int i = 0; i < 100; i++){
		b[i].flag = 0;
	}
	
	//建树
	buildTree(b,0,a,root);

	//计算树的叶节点个数
	int lenTree = 0;
	for(int i = 0; i < 100; i++){
		if(b[i].flag == 1)
			lenTree++;
	}
	//i<100是为了防止数组越界
	for(int i = 0,j = 0; i < 100&&j < lenTree-1; i++){
		if(b[i].flag == 1){
			printf("%d ",b[i].data);
			j++;
		}
	}
	for(int i = 100;i >= 0; i--){
		if(b[i].flag == 1){
			printf("%d\n",b[i].data);
			break;
		}
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值