03-树3 Tree Traversals Again(25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

figure1
Figure 1

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

思路:

本题实质为已知前序遍历和中序遍历,求后序遍历。
递归实现中序前序转后序操作,每次只把当前树的根节点放到后序遍历数组的最后边,注意由于后序遍历数组从后往前生成,所以递归时先递归右子树,再递归左子树。

注:
已知中序+前序,可得后序
已知中序+后序,可得前序
已知前序+后序,不可得中序

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#define N 50
using namespace std;
int pre_order[N];
int in_order[N];
int post_order[N];
int stack[N];

int pre_p = 0;
int in_p = 0;
int post_p = N-1; 
int top = 0;

void push(int x){//入栈 
	stack[top++] = x;	
}
int pop(){//出栈 
	return stack[--top];
}

void tranPost(int pre[], int in[], int len){
	if(len == 0)
		return;
	post_order[post_p--] = pre[0];
	int rootIndex = 0;
	for(;rootIndex < len;rootIndex++){
		if(in[rootIndex] == pre[0])
			break;
	}
	tranPost(pre+rootIndex+1,in+rootIndex+1,len-rootIndex-1);
	tranPost(pre+1,in,rootIndex);
}
int main(){
	int n;
	cin >> n;
	int p = 2*n;
	while(p--){
		string s;
		cin >> s;
		if(!s.compare("Push")){
			int num;
			cin >> num;
			push(num);
			pre_order[pre_p++] = num;
		}else{
			in_order[in_p++] = pop();
		}
	}
	tranPost(pre_order,in_order,n);
	for(int i = N-n; i < N-1; i++){
		cout << post_order[i] << " ";
	}
	cout << post_order[N-1] << endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值