PAT 1023-Have Fun with Numbers (20)

1023 Have Fun with Numbers (20)(20 分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798


解答:该题主要考察string字符串的处理,使用过程中注意string是char元素的集合,因此每一项的数值都是'0'+num; 

AC代码:

#include<iostream>
#include<string>
#include<algorithm>

using namespace std;

//将一个用字符串表示的数 得到其值为两倍的字符串 
void getDoubleValue(const string& s1, string& s2 );

int main()
{
	string s1, s2, seq1, seq2, result;
	cin >> s1;
	
	getDoubleValue(s1, s2);
	seq1.assign(s1.begin(), s1.end());
	if(s2.front() == '0')
		seq2.assign(s2.begin()+1, s2.end());
	else
	{
		seq2.assign(s2.begin(), s2.end());
	}
	s2 = seq2;
	sort(seq1.begin(), seq1.end());
	sort(seq2.begin(), seq2.end());
	bool isEqual = equal(seq1.begin(), seq1.end(), seq2.begin());
	if(isEqual == true)
	{
		cout << "Yes" << endl;
		cout << s2 << endl;
	}
	else
	{
		cout << "No" << endl;
		cout << s2 << endl;
	}
	return 0;
}
void getDoubleValue(const string& s1, string& s2)
{
	int addBit = 0;
	s2.assign(s1.size()+1, '0');
	
	for(int i = s1.size()-1; i >= 0; --i)
	{
		if( (s1[i] - '0') * 2 >= 10)
		{
			s2[i+1] = (s1[i] - '0') * 2 - 10 + addBit + '0';
			addBit = 1;
		}
		else
		{
			s2[i+1] = (s1[i] - '0')*2 + addBit + '0';
			addBit = 0;
		}
	}
	if(addBit == 1)
	{
		s2[0] = '1';
	}
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值