PAT 1014 Waiting in Line (30)

1014 Waiting in Line (30)(30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer~1~ is served at window~1~ while customer~2~ is served at window~2~. Customer~3~ will wait in front of window~1~ and customer~4~ will wait in front of window~2~. Customer~5~ will wait behind the yellow line.

At 08:01, customer~1~ is done and customer~5~ enters the line in front of window~1~ since that line seems shorter now. Customer~2~ will leave at 08:02, customer~4~ at 08:06, customer~3~ at 08:07, and finally customer~5~ at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output

08:07
08:06
08:10
17:00
Sorry

解答:该题解题步骤如下:首先读入每位顾客的操作时间及其操作次序,用#include<utility>中的pair<int, int>记录; 记录需要输出的顾客号及其时间,用pair<int, string>记录。然后对顾客进行初始排序,主要是填补开始的N*M个空缺,如果空缺仍存在,需要判定下。再然后,对队列中的元素进行pop和push,每次分别记录顾客开始时间和持续时间,在print中进行打印,如果开始时间 < 17:00,那么打印时间;否则打印“Sorry”。

本题的AC代码为:

#include<iostream>
#include<string>
#include<deque>
#include<vector>
#include<map>
#include<utility>
#include<sstream>

using namespace std;

string print(int totalTimes, int lastTime);
int main()
{
	int N, M, K, Q;  //N记录窗口数, M记录每个窗口可以容纳的人数, K记录顾客数, Q记录询问时间的顾客序号 
	deque<pair<int, int> > customer;  //记录顾客的序号和它需要的时间 
	deque<pair<int, string> > query;
	int minute;
	int seq;
	 
	cin >> N >> M >> K >> Q;
	
	for(int i = 0; i < K; ++i)
	{
		cin >> minute;
		customer.push_back(make_pair(i+1, minute));
	}
	for(int i = 0; i < Q; ++i)
	{
		cin >> seq;
		query.push_back(make_pair(seq, ""));
	}
	
	//排队
	vector<int> totalTimes(N, 0);
	vector< deque<pair<int, int> > > lines(N);
	int count = 0;
	//初始排队 
	for(int i = 0; i < M; ++i)
	{
		for(int j = 0; j < N; ++j)
		{
			if(customer.size()){
				pair<int, int> temp = customer.front(); 
				lines[j].push_back(temp);
				count++;
				customer.pop_front();	
			}
			else
			{
				break;
			}
		}
	} 

	//等待中排队
	while( count ){
		int minTime = 10000;
		int index = -1;
		int i;
		for(i = 0; i < N; ++i)
		{
			if( lines[i].size() && ( totalTimes[i] + lines[i].front().second < minTime ) )
			{
				minTime = totalTimes[i] + lines[i].front().second;
				index = i;
			}
		}
		//对index行进行处理
		if(index != -1)
			totalTimes[index] += lines[index].front().second;

		//如果是要询问的顾客,则打印时间 
		for(int i = 0; i < query.size(); ++i)
		{
			if( query[i].first == lines[index].front().first )
			{
				query[i].second = print(totalTimes[index] - lines[index].front().second, lines[index].front().second);
			}
		}
		
		lines[index].pop_front();
		count--;
		if(customer.size())
		{
			pair<int, int> temp = customer.front();
			lines[index].push_back(temp);
			count++;
			customer.pop_front();
		}
	}
	
	for(int i = 0; i < query.size(); ++i)
	{
		cout << query[i].second << endl;
	}
	return 0;
}

string print(int totalTimes, int lastTime)
{
	int hour, min;
	string sh, sm;
	
	hour = totalTimes / 60 + 8;
	min = totalTimes % 60;
	if(hour == 17 && min >= 0 || hour > 17)
	{
		return string("Sorry");
	}
	else
	{
		hour = (totalTimes + lastTime) / 60 + 8;
		min = (totalTimes + lastTime) % 60;
		stringstream ss,ss2;
		ss << hour;
		sh = ss.str();
		if(sh.size() == 1) sh.insert(0, "0");
		ss2 << min;
		sm = ss2.str();
		if(sm.size() == 1) sm.insert(0, "0");
		return string(sh + ":" + sm);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值