PAT 甲级 1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1​ aN1​​ N2​ aN2​​ ... NK​ aNK​​

where K is the number of nonzero terms in the polynomial, Ni​ and aNi​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK​<⋯<N2​<N1​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

结尾无空行

Sample Output:

3 2 1.5 1 2.9 0 3.2

题目大意

总之就是让你模拟两个多项式的加法。

题目分析

这道题的唯一需要考虑的点就是,怎么存储这两个多项式。

当然很容易想到用两个数组,一个存储指数exp一个存储系数coef,但是嘞,这种存储方式往往会浪费大量的空间,因为数组的大小是由最高项次数决定的,但是又不是每个多项式都会有那么多项。如果多项式是x^1000+1 ,数组存储的空间利用率都达不到1%

所以我们当然要用链表存储!!

但是我写错了

反正这也只是萌新小白初学者的记录博客 大家就别想着找答案了

思路就是用数组存储然后挨个加就完事儿了奥 自个儿去写 肘吧肘吧

柳大佬的AC代码(数组存储)

#include <iostream>
using namespace std;
int main()
{
    float c[1001]{0};
    int m,n,t;
    float num;
    scanf("%d", &m);
    for (int i = 0; i < m;i++)
    {
        scanf("%d%f", &t, &num);
        c[t] += num;
    }
    scanf("%d", &n);
    for (int i = 0; i < n;i++)
    {
        scanf("%d%f", &t, &num);
        c[t] += num;   
    }
    int cnt = 0;
    for (int i = 0; i < 1001;i++)
    {
        if(c[i]!=0)
            cnt++;
    }
    printf("%d", cnt);
    for (int i = 0; i >= 0;i--)
    {
        if(c[i]!=0.0)
            printf("%d %.1f", i, c[i]);
    }
    return 0;
}

3/5AC代码

#include <iostream>
#include <list>
#include <vector>
using namespace std;
list<vector<double>> pol1;
list<vector<double>> pol2;
void print(list<vector<double>>);
int main()
{
    int N;
    double exp, coef;
    cin >> N;
    for (int i = 0; i < N; i++)
    {
        cin >> exp >> coef;
        pol1.push_back({ exp,coef });
    }
    cin >> N;
    for (int i = 0; i < N; i++)
    {
        cin >> exp >> coef;
        pol2.push_back({ exp,coef });
    }
    list<vector<double>> pol3;
    auto i = pol1.begin();
    auto j = pol2.begin();
    while (i != pol1.end() || j != pol2.end())
    {
        if (i == pol1.end()) {
            pol3.push_back({ (*j)[0], (*j)[1] });
            j++;
        }
        else if (j == pol2.end()) 
        {
            pol3.push_back({ (*i)[0],(*i)[1] });
            i++;
        }
        else if ((*i)[0] > (*j)[0]) {
            pol3.push_back({ (*i)[0], (*i)[1] });
            i++;
        }
        else if ((*i)[0] < (*j)[0])
        {
            pol3.push_back({ (*j)[0],(*j)[1]});
            j++;
        }
        else
        {
            pol3.push_back({ (*i)[0],(*j)[1]+(*i)[1]});
            i++;
            j++;
        }
    }
    bool flag = 0;
    cout << pol3.size() << ' ';
    auto z = pol3.begin();
    while(z!=pol3.end())
    {
        if(flag == 1)
        {
            cout << ' ';
        }
        cout << (*z)[0] << ' '<<(*z)[1];
        if(flag == 0)
            flag = 1;
        z++;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值