树状数组_Rotate HDU2688



Problem Description
Recently yifenfei face such a problem that give you millions of positive integers,tell how many pairs i and j that satisfy F[i] smaller than F[j] strictly when i is smaller than j strictly. i and j is the serial number in the interger sequence. Of course, the problem is not over, the initial interger sequence will change all the time. Changing format is like this [S E] (abs(E-S)<=1000) that mean between the S and E of the sequece will Rotate one times.
For example initial sequence is 1 2 3 4 5.
If changing format is [1 3], than the sequence will be 1 3 4 2 5 because the first sequence is base from 0.
 

Input
The input contains multiple test cases.
Each case first given a integer n standing the length of integer sequence (2<=n<=3000000)
Second a line with n integers standing F[i](0<F[i]<=10000)
Third a line with one integer m (m < 10000)
Than m lines quiry, first give the type of quiry. A character C, if C is ‘R’ than give the changing format, if C equal to ‘Q’, just put the numbers of satisfy pairs.
 

Output
Output just according to said.
 

Sample Input
  
  
5 1 2 3 4 5 3 Q R 1 3 Q
 

Sample Output
  
  
10 8
题意:给定一个区间,求满足(ai<aj && i<j)的序对的个数.遇到Q输出答案,遇到R对一个子区间进行rotate.比如,子区间a,b,c进行rotate后变成b,c,a.值得注意的是给定R 1 3,实际子区间是[2,4].
分析:用树状数组能很好的求出原序列中正序对的个数ans,然后只需对子区间进行rotate并更新ans值.
这题时间卡得有点无语,963ms过的.并且有时会过不了.
AC代码:
#include <cstdio>
#include <cstring>
using namespace std;
#define lowbit(x) (x&-x)
#define maxn 3000030
typedef long long ll;
ll n,c[10005],a[maxn];
ll sum(ll x)
{
    ll res=0;
    while(x>0)
    {
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}

void add(ll x,ll d)
{
    while(x<=10005)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}

int main()
{
    while(scanf("%lld",&n)!=EOF)
    {

        for(ll i=1;i<=n;i++)
            scanf("%lld",&a[i]);


        memset(c,0,sizeof(c));

        ll ans=0;
        for(ll i=1;i<=n;i++)
        {
            add(a[i],1);
            ans+=sum(a[i]-1);

        }
        ll t;
        scanf("%lld",&t);
        while(t--)
        {
            char ch;
            getchar();
            scanf("%c",&ch);
            if(ch=='R')
            {
                ll l,r;
                scanf("%lld%lld",&l,&r);
                l++,r++;
                ll tmp=a[l];
                for(ll i=l+1;i<=r;i++)
                {
                    if(tmp<a[i]) ans--;
                    else if(tmp>a[i]) ans++;
                    a[i-1]=a[i];
                }
                a[r]=tmp;
            }
            else if(ch=='Q')
            {
            printf("%lld\n",ans);
            }
        }
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值