数据结构实验之二叉树三:统计叶子数

题目链接
Problem Description
已知二叉树的一个按先序遍历输入的字符序列,如abc,de,g,f, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。
Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。
Output
输出二叉树的叶子结点个数。
Example Input
abc,de,g,f,
Example Output
3

#include<iostream>
using namespace std;
typedef struct BiTNode{
    char ch;
    struct BiTNode *lchild;
    struct BiTNode *rchild;
}BiTNode,*BiTree;
char s[55];
int i;
BiTree Creat(char *s){
    BiTree T;
    if(s[i]==','){
        i++;
        return NULL;
    }
    else{
        T = new BiTNode;
        T->ch = s[i++];
        T->lchild = Creat(s);
        T->rchild = Creat(s);
    }
    return T;
}
int count1;
int NumberLeave(BiTree T){
    if(T==NULL)
        return 0;
    else{
        NumberLeave(T->lchild);
        if(T->lchild==NULL&&T->rchild==NULL)
            count1++;
        NumberLeave(T->rchild);
    }
    return count1;
}
int main(){
    while(cin>>s){
        BiTree T;
        i = 0;//重新赋值
        count1 = 0;//重新赋值
        T = Creat(s);
        cout<<NumberLeave(T)<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值