Nise-Anti-AK Problem(2018 ACM-ICPC 中国大学生程序设计竞赛线上赛 L题)

题目链接
Description:

Peppa has been learning math recently, he is trapped by a easy problem. He is given a sequence of n numbers, what he need to do is finding the number ai which have the largest number f(ai). The function f(x)=∑(i|x) where i goes form 0 to x, | is the symbol of or-by-bit calculate.

Input:

The first line of the input has an integer T(1<=T<=10), which represents the number of test cases.

In each test case, the first line of the input contains an integers n(1<=n<=1000)–the number of the integers, next line has n integers a[i] (1 <= a[i] <= 10000).

Output:

Each test case output an integer ai which have the largest number f(ai).

忽略每行输出的末尾多余空格
样例输入

1
3
2 3 5
样例输出

5
题目来源

2018 ACM-ICPC 中国大学生程序设计竞赛线上赛

解题思路:
直接按照公式套就可以了

#include<bits/stdc++.h>
using namespace std;
int main(){
    int n,a,b,mx,sum,flag;
    scanf("%d",&n);
    while(n--){
        mx = INT_MIN;
        scanf("%d",&a);
        for(int i = 0;i < a;i++){
            scanf("%d",&b);
            sum = 0;//每次都必须清零
            for(int j = 0;j <= b;j++)
                sum += (j | b);
            if(sum > mx){
                mx = sum;
                flag = b;
            }
        }
        printf("%d\n",flag);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值