题目链接
Problem Description
Given two sequences of numbers : a[1], a[2], … , a[N], and b[1], b[2], … , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], … , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1
Source
HDU 2007-Spring Programming Contest
解题思路:
kmp模板题
#include<bits/stdc++.h>
using namespace std;
//一开始定义为char pattern[10005],text[1000005],题目没说这个数字只有一位数......
int t,m,n,pattern[10005],text[1000005],prefix[10005];
void prefix_table(){
int i,j;
prefix[0] = -1;
i = 0,j = -1;
while(i < m){
if(j == -1 || pattern[i] == pattern[j])
prefix[++i] = ++j;
else
j = prefix[j];
}
return;
}
int kmp(){
int i,j;
i = 0,j = 0;
while(i < n){
if(j == -1 || text[i] == pattern[j]){
i++,j++;
if(j == m)
return i - j + 1;
}
else
j = prefix[j];
}
return -1;
}
int main(){
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&m);
for(int i = 0;i < n;i++)
scanf("%d",&text[i]);
for(int i = 0;i < m;i++)
scanf("%d",&pattern[i]);
if(n < m){
printf("-1\n");
continue;
}
prefix_table();
printf("%d\n",kmp());
}
return 0;
}