ACM程序设计 书中题目T

Description

Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input: The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000 (inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output: For each pair B and N in the input, output A as defined above on a line by itself.

Example Input:Example Output:
4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0
1
2
3
4
4
4
5
16
本题要输入B和N,找出整数A使A的N次方最接近B;
开始时我是用pow(B,1.0/N),然后得出两个最接近的数,判断谁的N次方更接近B。代码如下:
#include <bits/stdc++.h>
using namespace std;
int main()
{
        double a,b,sum;
        int p[1];
        while(cin>>a>>b)
        {
                if(a==0&&b==0)
                        break;
                sum=pow(a,1.0/b);
                p[0]=sum+1;p[1]=sum;
                if(fabs(pow(p[0],b)-a)<fabs(pow(p[1],b)-a))
                        sum=p[0];
                else
                        sum=p[1];
                cout<<sum<<endl;
        }
}
但测试正确提交错误,且找不出错误,于是换思路,从0开始扫描,提交正确,代码如下:
#include <bits/stdc++.h>
using namespace std;
int main()
{
        int b,n,x,y,i;
        while(cin>>b>>n)
        {
                if(b==0&&n==0)
                        break;
                for(i=0;i<b;i++)
                {
                        x=pow(i,n)-b;
                        y=pow(i+1,n)-b;
                        if(x<0&&y>=0)
                        {
                                if(fabs(x)<fabs(y))
                                cout<<i<<endl;
                                else cout<<i+1<<endl;
                        }
                }
        }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值