Problem P-16 Fatmouse trade

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.


Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


Sample Input


5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


Sample Output

13.333
31.500


题目介绍
Fat mouse 拿着它的M磅猫粮去换取食物,有n间房间,第i间有J[i]磅食物,用F[i]*a%换取J[i]*a%的食物,问最多换多少食物,保留三位小数
解题思路
先交易a大的,这样能确保交易到最多的食物,而a用J[i]/F[i]来表示,先将a由大到小排序,然后计算,并输出
源代码
#include<bits/stdc++.h>
using namespace std;
struct Mouse
{
        double J;
        double F;
        double a;
};
bool Comp(Mouse d1,Mouse d2)
{
        if(d1.a!=d2.a)
                return d1.a>d2.a;
        else
                return d1.F<d2.F;
}
int main()
{
        vector<Mouse>v;
        Mouse mouse;
        int m,n,i;
        cout.precision(3);
        double sum;
        while(cin>>m>>n)
        {
                if(m==-1&&n==-1)
                        break;
                v.clear();
                sum=0.0;
                for(i=0;i<n;i++)
                {
                        cin>>mouse.J>>mouse.F;
                        mouse.a=mouse.J/mouse.F;
                        v.push_back(mouse);
                }
                sort(v.begin(),v.end(),Comp);
                for(i=0;i<v.size();i++)
                {
                        if(m>=v[i].F)
                        {
                                sum=sum+v[i].J;
                                m=m-v[i].F;
                        }
                        else
                        {
                                sum=sum+m*v[i].a;
                        break;
                        }
                }
                cout<<fixed<<sum<<endl;
        }
        return 0;


}

cout.precision(3)是设置有效数字

setprecsion(n)和precision(n)的区别

setprecsion(n)是格式控制符,precision(n)是流对象的成员函数,用法分别如下:
如要输出圆周率的pi=3.141592四位小数,
cout<<setprecision(4)<<pi;
cout.precision(4);cout<<pi;


setprecision(n) 设显示小数精度为n位 
setw(n) 设域宽为n个字符 
这个控制符的意思是保证输出宽度为n。如: 
cout<<setw(3)<<1<<setw(3)<<10<<setw(3)<<100; 输出结果为 
1 10100 (默认是右对齐)当输出长度大于3时(<<1000),setw(3)不起作用。 
setioflags(ios::fixed) 固定的浮点显示 
setioflags(ios::scientific) 指数表示 
setiosflags(ios::left) 左对齐 
setiosflags(ios::right) 右对齐 
setiosflags(ios::skipws 忽略前导空白 
setiosflags(ios::uppercase) 16进制数大写输出 
setiosflags(ios::lowercase) 16进制小写输出 
setiosflags(ios::showpoint) 强制显示小数点 
setiosflags(ios::showpos) 强制显示符号 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值