【HDU】5606 并查集

Problem Description
There is a tree(the tree is a connected graph which contains n points and n−1 edges),the points are labeled from 1 to n,which edge has a weight from 0 to 1,for every point i∈[1,n],you should find the number of the points which are closest to it,the clostest points can contain i itself.
 

Input
the first line contains a number T,means T test cases.

for each test case,the first line is a nubmer n,means the number of the points,next n-1 lines,each line contains three numbers u,v,w,which shows an edge and its weight.

T≤50,n≤105,u,v∈[1,n],w∈[0,1]
 

Output
for each test case,you need to print the answer to each point.

in consideration of the large output,imagine ansi is the answer to point i,you only need to output,ans1 xor ans2 xor ans3.. ansn.
 

Sample Input
1
3
1 2 0
2 3 1
 

Sample Output
1

in the sample.

$ans_1=2$

$ans_2=2$

$ans_3=1$

$2~xor~2~xor~1=1$,so you need to output 1.

题意描述:

题意:一棵树,权值只有0和1,找到每个点与之相距最近的点的个数,

(包括这个点自己,也就是说,等价于找每个点与之相距为0的点的个数)。

如果点与相连的点距离都为1,则无需考虑,肯定只能与自己相连; 

思路:运用并查集,找出点与点距离为0构成的块,并记录根节点的连通数目(包括自己); 

#include<stdio.h>
using namespace std;
int a[100005];
int vag[100005];
int find(int tt)
{
    if(tt!=a[tt])
        a[tt]=find(a[tt]);
    return a[tt];
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int i,j,k,n;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            a[i]=i;
            vag[i]=1;
        }
        for(i=1;i<n;i++)
        {
            int zx,zy,zz;
            scanf("%d%d%d",&zx,&zy,&zz);
            int dx=find(zx);
            int dy=find(zy);
            if(!zz)
            {
                a[dx]=dy;
                vag[dy]=vag[dy]+vag[dx];
            }
        }
        int ans=0;
        for(i=1;i<=n;i++)
        {
            int ax=find(i);
            ans=ans^(vag[ax]);
        }
        printf("%d\n",ans);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值