杭电1710-Binary Tree Traversals

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2. 

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder. 

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder. 

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r. 

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence. 

Input

The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree. 

Output

For each test case print a single line specifying the corresponding postorder sequence. 

Sample Input

9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6

Sample Output

7 4 2 8 9 5 6 3 1

解题思路

题目意思是通过前序遍历和中序遍历找出后序遍历。由前序遍历的性质可知,根节点必定是第一个数,因此可以通过前序遍历的根节点找到中序遍历的根节点所在,并通过根节点区分左右子树。确定根节点后又根据前序遍历和中序遍历的性质分别找出每一个子树的根节点所在,从而重构二叉树。重构出二叉树后再进行后序遍历得出答案

代码

#include<bits/stdc++.h>
using namespace std;	
typedef struct node{
	struct node *l;
	struct node *r;
	int num;
}*tree;
int mid[5005],pre[5005],post[5005];
int create(tree &rt,int *pre,int *mid,int len){
	int pos = -1;
	for(int i = 0;i < len;i++){
		if(mid[i] == pre[0]){//找出根节点
			pos = i;
			break;	
		}
	}
	//cout<<pos<<endl;
	rt = new node;
	rt->num = pre[0];
	if(pos == 0){
		rt->l = NULL;
	}else{
		create(rt->l,pre + 1,mid,pos);//根据前序遍历和中序遍历构造左子树 
		//传入根节点,前序的根节点,中序的根节点,树的长度
	}
	if(pos == len - 1){
		rt->r = NULL;
	}else{
		create(rt->r,pre + pos + 1,mid + pos + 1,len - pos - 1);//根据前序遍历和中序遍历构造右子树 
	}
}
void print(tree &rt,int &k){
	if(rt == NULL){
		return;
	}
	print(rt->l,k);
	print(rt->r,k);
	post[k++] = rt->num;
	free(rt);
}
int main(){
	int n;
	while(~scanf("%d",&n)){
		memset(pre,0,sizeof(pre));
		memset(mid,0,sizeof(mid));
		memset(post,0,sizeof(post));
		tree rt;
		for(int i = 0;i < n;i++){
			cin>>pre[i];
		}
		for(int i = 0;i < n;i++){
			cin>>mid[i];
		}
		int k = 0;
		create(rt,pre,mid,n);
		print(rt,k);
		cout<<post[0];
		for(int i = 1;i < n;i++){
			cout<<" "<<post[i];
		}
		cout<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值