《ACM程序设计》书中题目―Y

Description
The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.
Input
The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.
Output
For each test case, print the string that follows the given string.
Sample Input


3
122344111
1111111111
12345

Sample Output


1122132431
101
1112131415

1、题目:先输入一串数字,让你先输出连续的数字的数量再输出数字,直到数字结束。
2、思路:输入一串数字,利用循环输出即可。
3、代码:
#include<iostream>
#include<string>
using namespace std;
int main()
{
string nn;
int t,i,j;
while(cin>>t)
{
while(t--)
{
j=1;
cin>>nn;
for(i=0;i<nn.size();i++)
    {
    if(nn[i]==nn[i+1])
        j++;
    else
        {
        cout<<j<<nn[i];
        j=1;
        }
    }
cout<<endl;
}
}
return 0;
}
4、总结:仔细认真即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值